summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.7.2.ebuild')
-rw-r--r--dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.7.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.7.2.ebuild b/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.7.2.ebuild
new file mode 100644
index 000000000000..f1c8887545ce
--- /dev/null
+++ b/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.7.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="FastGettext / Rails integration"
+HOMEPAGE="https://github.com/grosser/gettext_i18n_rails"
+SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rails:4.2 dev-ruby/activerecord:4.2[sqlite] dev-ruby/temple )"
+ruby_add_rdepend ">=dev-ruby/fast_gettext-0.9.0"
+
+all_ruby_prepare() {
+ rm Gemfile Gemfile.lock || die
+
+ # Remove specs for slim and hamlet, template engines we don't package.
+ rm spec/gettext_i18n_rails/slim_parser_spec.rb spec/gettext_i18n_rails/haml_parser_spec.rb || die
+
+ # Test against Rails 4.2.0
+ sed -e '1igem "rails", "~>4.2.0"' -i spec/spec_helper.rb || die
+}