summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/gruff/gruff-0.5.1.ebuild')
-rw-r--r--dev-ruby/gruff/gruff-0.5.1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-ruby/gruff/gruff-0.5.1.ebuild b/dev-ruby/gruff/gruff-0.5.1.ebuild
deleted file mode 100644
index c94fcd28467b..000000000000
--- a/dev-ruby/gruff/gruff-0.5.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-USE_RUBY="ruby19 ruby20"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.md RELEASE.md"
-
-RUBY_FAKEGEM_EXTRAINSTALL="assets rails_generators"
-
-inherit ruby-fakegem
-
-ruby_add_rdepend '>=dev-ruby/rmagick-2'
-ruby_add_bdepend "
- test? (
- dev-ruby/hoe
- )"
-
-DESCRIPTION="RMagick Implementation for JRuby"
-HOMEPAGE="http://rubyforge.org/projects/gruff/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~x86-macos"
-IUSE=""
-
-RUBY_PATCHES=(
- ${PN}-0.3.6-spider.patch
-)
-
-# imagemagick is an indirect dependency through rmagick. However, for
-# gruff to work properly imagemagick needs to be compiled with
-# truetype support and this cannot be expressed in the rmagick
-# dependency. Test also require imagemagick to have jpeg support.
-DEPEND="${DEPEND} test? ( media-gfx/imagemagick[jpeg,truetype] )"
-RDEPEND="${RDEPEND} media-gfx/imagemagick[truetype]"
-
-ruby_add_bdepend "test? ( dev-ruby/test-unit )"
-
-each_ruby_test() {
- ruby-ng_testrb-2 test/test_*.rb
-}