summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/httparty')
-rw-r--r--dev-ruby/httparty/Manifest1
-rw-r--r--dev-ruby/httparty/httparty-0.16.0.ebuild49
2 files changed, 0 insertions, 50 deletions
diff --git a/dev-ruby/httparty/Manifest b/dev-ruby/httparty/Manifest
index 57372b1397bd..c11e7ed56b25 100644
--- a/dev-ruby/httparty/Manifest
+++ b/dev-ruby/httparty/Manifest
@@ -1,2 +1 @@
-DIST httparty-0.16.0.gem 89088 BLAKE2B 27715c6760a9adeec289a005f89de219b32e6ad5c3f937478ad4187df895096f9375b0d20a4b33c1c62b96de6313017a713a036247756a96fe9366e7c1e77247 SHA512 c523ab3555d0a86e2df53e800be57b88f40bb680e7df31e754ddc3e76728eb2228e6ddbe9a3e580c4c604a126ebcd33be79dfde3758faf99aadbba4d30d9508d
DIST httparty-0.16.2.gem 89600 BLAKE2B 581b5fcadf59bb50864b2fa6d1aae220ff9881bba53363601c6e70c3291dc2cee351a8f42b1946ad516cdcab5a85b832e4260f04394e54255e0cd76bc6860d5e SHA512 13efbacb9ee0325fbb185279ca9f7ffcc0131189ccf98d9889c6a1b6bcfa04fd7cbc6d1393bffe69a5a813a2f54f70b5926e176305fa70480dd0902968c894d0
diff --git a/dev-ruby/httparty/httparty-0.16.0.ebuild b/dev-ruby/httparty/httparty-0.16.0.ebuild
deleted file mode 100644
index 472d30ad10ff..000000000000
--- a/dev-ruby/httparty/httparty-0.16.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy"
-HOMEPAGE="https://jnunemaker.github.com/httparty"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE=""
-
-ruby_add_rdepend '>=dev-ruby/multi_xml-0.5.2'
-
-ruby_add_bdepend 'test? ( dev-ruby/webmock )'
-
-all_ruby_prepare() {
- # Remove bundler
- rm Gemfile || die
- sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
-
- # Avoid test dependency on cucumber. We can't run the features since
- # they depend on mongrel which is no longer packaged.
- sed -i -e '/cucumber/I s:^:#:' Rakefile || die
-
- # Avoid test dependency on simplecov
- sed -i -e '/simplecov/I s:^:#:' \
- -e '1i require "cgi"; require "delegate"' spec/spec_helper.rb || die
-
- # Avoid test that works standalone but fails in the suite
- sed -i -e '/calls block given to perform with each redirect/,/^ end/ s:^:#:' spec/httparty/request_spec.rb
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc examples/*
-}