summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/rb-inotify')
-rw-r--r--dev-ruby/rb-inotify/Manifest1
-rw-r--r--dev-ruby/rb-inotify/metadata.xml8
-rw-r--r--dev-ruby/rb-inotify/rb-inotify-0.9.5-r1.ebuild39
-rw-r--r--dev-ruby/rb-inotify/rb-inotify-0.9.5.ebuild39
4 files changed, 87 insertions, 0 deletions
diff --git a/dev-ruby/rb-inotify/Manifest b/dev-ruby/rb-inotify/Manifest
new file mode 100644
index 000000000000..e7788a1d563a
--- /dev/null
+++ b/dev-ruby/rb-inotify/Manifest
@@ -0,0 +1 @@
+DIST rb-inotify-0.9.5.gem 14336 SHA256 69559fc3d790c275b90f55f8c76cde94a999e3400f5a51f2e0d463a0a2e8ad4d SHA512 1ecc0142ed44358a2f51403736533e9854b5fc13cb81b552eb866310b60535b14e2ac6bfb6ee53bc1ee65ac14e51fc5a981e52f843607dbb3d8390c1d6c13e60 WHIRLPOOL 19d7d1f7ca8e65a297de94fae3311c1bc8d9942aa47dc2c92202ce0adb8f04d62ac94f0c51c76a6bd263e773df2481b2337b6576f818cff7bf4fd2ccaa30fd27
diff --git a/dev-ruby/rb-inotify/metadata.xml b/dev-ruby/rb-inotify/metadata.xml
new file mode 100644
index 000000000000..ec3d5107a1e8
--- /dev/null
+++ b/dev-ruby/rb-inotify/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">nex3/rb-inotify</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rb-inotify/rb-inotify-0.9.5-r1.ebuild b/dev-ruby/rb-inotify/rb-inotify-0.9.5-r1.ebuild
new file mode 100644
index 000000000000..526fd5bfeda0
--- /dev/null
+++ b/dev-ruby/rb-inotify/rb-inotify-0.9.5-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+RUBY_FAKEGEM_GEMSPEC="rb-inotify.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thorough inotify wrapper for Ruby using FFI"
+HOMEPAGE="https://github.com/nex3/rb-inotify"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "virtual/ruby-ffi"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on jeweler.
+ sed -i -e '/:build/ s:^:#:' -e '/module Jeweler/,/^end/ s:^:#:' -e '/class Jeweler/,/^end/ s:^:#:' Rakefile || die
+
+ # Remove mandatory markup processor from yard options, bug 436112.
+ sed -i -e '/maruku/d' .yardopts || die
+}
diff --git a/dev-ruby/rb-inotify/rb-inotify-0.9.5.ebuild b/dev-ruby/rb-inotify/rb-inotify-0.9.5.ebuild
new file mode 100644
index 000000000000..10bbb9116bb2
--- /dev/null
+++ b/dev-ruby/rb-inotify/rb-inotify-0.9.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+
+RUBY_FAKEGEM_GEMSPEC="rb-inotify.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thorough inotify wrapper for Ruby using FFI"
+HOMEPAGE="https://github.com/nex3/rb-inotify"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~x64-macos"
+IUSE=""
+
+ruby_add_rdepend "virtual/ruby-ffi"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on jeweler.
+ sed -i -e '/:build/ s:^:#:' -e '/module Jeweler/,/^end/ s:^:#:' -e '/class Jeweler/,/^end/ s:^:#:' Rakefile || die
+
+ # Remove mandatory markup processor from yard options, bug 436112.
+ sed -i -e '/maruku/d' .yardopts || die
+}