summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ruby-gettext/ruby-gettext-3.1.1.ebuild')
-rw-r--r--dev-ruby/ruby-gettext/ruby-gettext-3.1.1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-ruby/ruby-gettext/ruby-gettext-3.1.1.ebuild b/dev-ruby/ruby-gettext/ruby-gettext-3.1.1.ebuild
new file mode 100644
index 000000000000..b9bc5be47bd8
--- /dev/null
+++ b/dev-ruby/ruby-gettext/ruby-gettext-3.1.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_NAME="${PN/ruby-/}"
+RUBY_FAKEGEM_VERSION="${PV%_*}"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_EXTRAINSTALL="po"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby GetText Package is Native Language Support Library and Tools modeled after GNU gettext package"
+HOMEPAGE="http://www.yotabanana.com/hiki/ruby-gettext.html"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc"
+IUSE="doc test"
+SLOT="0"
+LICENSE="Ruby"
+
+ruby_add_rdepend ">=dev-ruby/locale-2.0.5 dev-ruby/text"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ dev-ruby/racc"
+ruby_add_bdepend "test? (
+ dev-ruby/test-unit:2
+ dev-ruby/test-unit-rr )"
+
+RDEPEND+=" sys-devel/gettext"
+DEPEND+=" sys-devel/gettext"
+
+all_ruby_prepare() {
+ # Fix broken racc invocation
+ sed -i -e '/command_line/ s/#{racc}/-S racc/' Rakefile || die
+
+ # Avoid bundler dependency
+ sed -i -e '/bundler/,/helper.install/ s:^:#:' \
+ -e 's/helper.gemspec/Gem::Specification.new/' Rakefile || die
+
+ # Avoid dependency on developer-specific tools.
+ sed -i -e '/notify/ s:^:#:' test/run-test.rb || die
+}
+
+each_ruby_test() {
+ # Upstream tries to daisy-chain rake calls but they fail badly
+ # with our setup, so run it manually.
+ ${RUBY} test/run-test.rb || die "tests failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+}