summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/trollop/trollop-2.1.3.ebuild')
-rw-r--r--dev-ruby/trollop/trollop-2.1.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/trollop/trollop-2.1.3.ebuild b/dev-ruby/trollop/trollop-2.1.3.ebuild
new file mode 100644
index 000000000000..7c18c245b104
--- /dev/null
+++ b/dev-ruby/trollop/trollop-2.1.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="FAQ.txt History.txt README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Trollop is a commandline option parser for Ruby"
+HOMEPAGE="https://manageiq.github.io/trollop/"
+LICENSE="MIT"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="2"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/chronic )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundle/ s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ MUTANT=true ${RUBY} -S rake test || die "Tests failed."
+}