summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/holotz-castle')
-rw-r--r--games-arcade/holotz-castle/holotz-castle-1.3.14.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/games-arcade/holotz-castle/holotz-castle-1.3.14.ebuild b/games-arcade/holotz-castle/holotz-castle-1.3.14.ebuild
index 2f747c7d07a5..0e83e0023282 100644
--- a/games-arcade/holotz-castle/holotz-castle-1.3.14.ebuild
+++ b/games-arcade/holotz-castle/holotz-castle-1.3.14.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit eutils toolchain-funcs games
DESCRIPTION="2D platform game"
@@ -20,15 +20,16 @@ RDEPEND="virtual/opengl
media-libs/libsdl
media-libs/sdl-ttf
media-libs/sdl-image"
-DEPEND="${RDEPEND}"
+DEPEND=${RDEPEND}
S=${WORKDIR}/${P}-src
-PATCHES=(
- "${FILESDIR}"/${P}-build.patch
- "${FILESDIR}"/${P}-gcc44.patch
- "${FILESDIR}"/${P}-underlink.patch
-)
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-underlink.patch
+}
src_compile() {
tc-export AR