summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/snes9x/files/snes9x-1.59-build-system.patch')
-rw-r--r--games-emulation/snes9x/files/snes9x-1.59-build-system.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-emulation/snes9x/files/snes9x-1.59-build-system.patch b/games-emulation/snes9x/files/snes9x-1.59-build-system.patch
new file mode 100644
index 000000000000..2d8f9f05e59f
--- /dev/null
+++ b/games-emulation/snes9x/files/snes9x-1.59-build-system.patch
@@ -0,0 +1,40 @@
+--- snes9x-1.59/unix/configure.ac
++++ snes9x-1.59/unix/configure.ac
+@@ -56,37 +56,6 @@
+ # *** Execution begins here ***
+ # *****************************
+
+-# Test what compiler flags we should use.
+-
+-AC_ARG_ENABLE([debug],
+- [AS_HELP_STRING([--enable-debug],
+- [leave debug information in the final binary (default: no)])],
+- [], [enable_debug="no"])
+-
+-if test "x$enable_debug" = "xyes"; then
+- AC_S9X_COMPILER_FLAG([-g], [g])
+- AC_S9X_COMPILER_FLAG([-O0], [o0])
+-else
+- AC_S9X_COMPILER_FLAG([-O3], [o3], [
+- AC_S9X_COMPILER_FLAG([-O2], [o2], [
+- AC_S9X_COMPILER_FLAG([-O1], [o1])])])
+- AC_S9X_COMPILER_FLAG([-fomit-frame-pointer], [omit_frame_pointer])
+-fi
+-
+-AC_ARG_ENABLE([mtune],
+- [AS_HELP_STRING([--enable-mtune],
+- [use the specified value for the -mtune/-mcpu flag (default: no)])],
+- [], [enable_mtune="no"])
+-
+-if test "x$enable_mtune" != "xno"; then
+- AC_S9X_COMPILER_FLAG([-mtune="$enable_mtune"], [mtune],
+- [
+- AC_MSG_WARN([-mtune failed, trying -mcpu...])
+- AC_S9X_COMPILER_FLAG([-mcpu="$enable_mtune"], [mcpu],
+- [AC_MSG_ERROR([Please specify a working value for --enable-mtune.])])
+- ])
+-fi
+-
+ AC_S9X_COMPILER_FLAG([-fno-exceptions], [no_exceptions])
+ AC_S9X_COMPILER_FLAG([-fno-rtti], [no_rtti])
+ AC_S9X_COMPILER_FLAG([-pedantic], [pedantic])