summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild')
-rw-r--r--games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild45
1 files changed, 26 insertions, 19 deletions
diff --git a/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild b/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild
index 16ebc3d31501..6e555ab07fc3 100644
--- a/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild
+++ b/games-fps/ut2004-bonuspack-ece/ut2004-bonuspack-ece-1-r3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=2
+EAPI=5
MOD_DESC="Editor's Choice Edition bonus pack"
MOD_NAME="Editor's Choice Edition"
@@ -14,40 +14,47 @@ HOMEPAGE="http://www.unrealtournament2004.com/"
SRC_URI="mirror://3dgamers/unrealtourn2k4/Missions/${MY_P}
http://0day.icculus.org/ut2004/${MY_P}
ftp://ftp.games.skynet.be/pub/misc/${MY_P}
- http://sonic-lux.net/data/mirror/ut2004/${MY_P}"
+ http://sonic-lux.net/data/mirror/ut2004/${MY_P}
+ http://unrealmassdestruction.com/downloads/ut2k4/essentials/UT2004-ONSBonusMapPack.zip"
LICENSE="ut2003"
KEYWORDS="amd64 x86"
IUSE=""
+src_unpack() {
+ unpack ${MY_P}
+ cd UT2004MegaPack/Maps || die
+ unpack UT2004-ONSBonusMapPack.zip # bug #278002
+}
+
src_prepare() {
mv -f UT2004MegaPack/* . || die
- rmdir UT2004MegaPack
+ rmdir UT2004MegaPack || die
- rm -r Music Speech
+ rm -r Music Speech || die
# Remove megapack files which are not in ece
- rm Animations/ONSNewTank-A.ukx
- rm Help/ReadMePatch.int.txt
+ rm Animations/ONSNewTank-A.ukx || die
+ rm Help/ReadMePatch.int.txt || die
# Help/{DebuggerLogo.bmp,InstallerLogo.bmp,Unreal.ico,UnrealEd.ico}
# are not in megapack.
# Keep new Help/UT2004Logo.bmp
# Manual dir does not exist in megapack
- rm Maps/{AS*,CTF*,DM*}
- rm Sounds/A_Announcer_BP2.uax
- rm StaticMeshes/{JumpShipObjects.usx,Ty_RocketSMeshes.usx}
- rm System/{A*,b*,B*,CacheRecords.ucl}
- rm System/{*.det,*.est,*.frt,*.itt,*.kot}
- rm System/{CTF*,D*,Editor*,G*,I*,L*,ONS-Arc*,Onslaught.*,*.md5}
- rm System/{u*,U*,V*,X*,Core.u,Engine.u,F*,*.ucl,Sk*}
- rm Textures/{J*,j*,T*}
- rm -r Web
+ rm Maps/{AS*,CTF*,DM*} || die
+ rm Sounds/A_Announcer_BP2.uax || die
+ rm StaticMeshes/{JumpShipObjects.usx,Ty_RocketSMeshes.usx} || die
+ rm System/{A*,b*,B*,CacheRecords.ucl} || die
+ rm System/{*.det,*.est,*.frt,*.itt,*.kot} || die
+ rm System/{CTF*,D*,Editor*,G*,I*,L*,Onslaught.*,*.md5} || die
+ rm System/{u*,U*,V*,X*,Core.u,Engine.u,F*,*.ucl,Sk*} || die
+ rm Textures/{J*,j*,T*} || die
+ rm -r Web || die
# The file lists of ut2004-3369-r1 and -r2 are identical
# Remove files owned by ut2004-3369-r2
- rm Help/UT2004Logo.bmp
+ rm Help/UT2004Logo.bmp || die
# The 2 Manifest files have not changed
- rm System/{Manifest.in{i,t},OnslaughtFull.int}
- rm System/{Core.int,Engine.int,Setup.int,Window.int}
- rm System/{OnslaughtFull.u,OnslaughtBP.u}
+ rm System/{Manifest.in{i,t},OnslaughtFull.int} || die
+ rm System/{Core.int,Engine.int,Setup.int,Window.int} || die
+ rm System/{OnslaughtFull.u,OnslaughtBP.u} || die
}