summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-kids/gcompris/gcompris-0.91.ebuild')
-rw-r--r--games-kids/gcompris/gcompris-0.91.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-kids/gcompris/gcompris-0.91.ebuild b/games-kids/gcompris/gcompris-0.91.ebuild
new file mode 100644
index 000000000000..052f974c10bb
--- /dev/null
+++ b/games-kids/gcompris/gcompris-0.91.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils desktop
+
+DESCRIPTION="full featured educational application for children from 2 to 10"
+HOMEPAGE="https://gcompris.net/"
+SRC_URI="http://gcompris.net/download/qt/src/gcompris-qt-${PV}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}-qt-${PV}"
+
+RDEPEND="
+ dev-qt/qtcore
+ dev-qt/qtgraphicaleffects
+ dev-qt/qtgui
+ dev-qt/qtmultimedia[qml]
+ dev-qt/qtnetwork
+ dev-qt/qtquickcontrols
+ dev-qt/qtsensors[qml]
+ dev-qt/qtsvg
+ dev-qt/qtxml
+ dev-qt/qtxmlpatterns"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools"
+
+src_configure() {
+ local mycmakeargs=(
+ # TODO: add box2d support
+ -DQML_BOX2D_MODULE=disabled
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ domenu org.kde.gcompris.desktop
+}