summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-simulation/openrct2')
-rw-r--r--games-simulation/openrct2/files/openrct2-0.2.6-gtest-1.10.patch20
-rw-r--r--games-simulation/openrct2/openrct2-0.2.6.ebuild1
2 files changed, 21 insertions, 0 deletions
diff --git a/games-simulation/openrct2/files/openrct2-0.2.6-gtest-1.10.patch b/games-simulation/openrct2/files/openrct2-0.2.6-gtest-1.10.patch
new file mode 100644
index 000000000000..f0805f408552
--- /dev/null
+++ b/games-simulation/openrct2/files/openrct2-0.2.6-gtest-1.10.patch
@@ -0,0 +1,20 @@
+From 8feab6138724722146b1c6d521431556686068d3 Mon Sep 17 00:00:00 2001
+From: Conrad Kostecki <conrad@kostecki.com>
+Date: Wed, 19 Aug 2020 22:56:51 +0200
+Subject: [PATCH] ReplayTests: Add support for >=gtest-1.10
+
+Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
+---
+ test/tests/ReplayTests.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/test/tests/ReplayTests.cpp b/test/tests/ReplayTests.cpp
+index 653aa97657f..1443d1c862d 100644
+--- a/test/tests/ReplayTests.cpp
++++ b/test/tests/ReplayTests.cpp
+@@ -117,4 +117,5 @@ struct PrintReplayParameter
+ }
+ };
+
++GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST(ReplayTests);
+ INSTANTIATE_TEST_CASE_P(Replay, ReplayTests, testing::ValuesIn(GetReplayFiles()), PrintReplayParameter());
diff --git a/games-simulation/openrct2/openrct2-0.2.6.ebuild b/games-simulation/openrct2/openrct2-0.2.6.ebuild
index 6a7f824c16d3..856708edc6e4 100644
--- a/games-simulation/openrct2/openrct2-0.2.6.ebuild
+++ b/games-simulation/openrct2/openrct2-0.2.6.ebuild
@@ -73,6 +73,7 @@ S="${WORKDIR}/${MY_PN}-${PV}"
PATCHES=(
"${FILESDIR}/${PN}-0.2.4-include-additional-paths.patch"
+ "${FILESDIR}/${PN}-0.2.6-gtest-1.10.patch"
)
src_unpack() {