summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-sports/foobillard/foobillard-3.0a-r1.ebuild')
-rw-r--r--games-sports/foobillard/foobillard-3.0a-r1.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/games-sports/foobillard/foobillard-3.0a-r1.ebuild b/games-sports/foobillard/foobillard-3.0a-r1.ebuild
index 1e0053bfc696..c25b7f5ae4e4 100644
--- a/games-sports/foobillard/foobillard-3.0a-r1.ebuild
+++ b/games-sports/foobillard/foobillard-3.0a-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools desktop flag-o-matic toolchain-funcs
+EAPI=7
+
+inherit autotools desktop flag-o-matic
DESCRIPTION="8ball, 9ball, snooker and carambol game"
HOMEPAGE="http://foobillard.sourceforge.net/"
@@ -22,17 +23,20 @@ RDEPEND="x11-libs/libXaw
sdl? ( media-libs/libsdl[video] )
!sdl? ( media-libs/freeglut )
"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-no_nvidia.patch
+ "${FILESDIR}"/${P}-freetype_pkgconfig.patch
+ "${FILESDIR}"/${P}-fbsd.patch
+ "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-gl-clamp.patch
+)
src_prepare() {
default
- eapply \
- "${FILESDIR}"/${P}-no_nvidia.patch \
- "${FILESDIR}"/${P}-freetype_pkgconfig.patch \
- "${FILESDIR}"/${P}-fbsd.patch \
- "${FILESDIR}"/${P}-as-needed.patch \
- "${FILESDIR}"/${P}-gl-clamp.patch
+
mv configure.{in,ac} || die
rm aclocal.m4