summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/trigger/files/trigger-0.6.1-gcc6.patch39
-rw-r--r--games-sports/trigger/trigger-0.6.1-r1.ebuild6
2 files changed, 43 insertions, 2 deletions
diff --git a/games-sports/trigger/files/trigger-0.6.1-gcc6.patch b/games-sports/trigger/files/trigger-0.6.1-gcc6.patch
new file mode 100644
index 000000000000..38822287c61d
--- /dev/null
+++ b/games-sports/trigger/files/trigger-0.6.1-gcc6.patch
@@ -0,0 +1,39 @@
+Bug: https://bugs.gentoo.org/617886
+
+--- a/src/pengine/tinyxmlparser.cpp
++++ b/src/pengine/tinyxmlparser.cpp
+@@ -326,14 +326,14 @@
+ if ( !p || !*p )
+ {
+ SetError( TIXML_ERROR_DOCUMENT_EMPTY );
+- return false;
++ return NULL;
+ }
+
+ p = SkipWhiteSpace( p );
+ if ( !p )
+ {
+ SetError( TIXML_ERROR_DOCUMENT_EMPTY );
+- return false;
++ return NULL;
+ }
+
+ while ( p && *p )
+@@ -541,7 +541,7 @@
+ if ( !p || !*p || *p != '<' )
+ {
+ if ( document ) document->SetError( TIXML_ERROR_PARSING_ELEMENT );
+- return false;
++ return NULL;
+ }
+
+ p = SkipWhiteSpace( p+1 );
+@@ -551,7 +551,7 @@
+ if ( !p || !*p )
+ {
+ if ( document ) document->SetError( TIXML_ERROR_FAILED_TO_READ_ELEMENT_NAME );
+- return false;
++ return NULL;
+ }
+
+ TIXML_STRING endTag ("</");
diff --git a/games-sports/trigger/trigger-0.6.1-r1.ebuild b/games-sports/trigger/trigger-0.6.1-r1.ebuild
index 88ead4153a06..0b6083919971 100644
--- a/games-sports/trigger/trigger-0.6.1-r1.ebuild
+++ b/games-sports/trigger/trigger-0.6.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -7,7 +7,7 @@ inherit eutils
MY_PN=${PN}-rally
MY_P=${MY_PN}-${PV}
DESCRIPTION="Free OpenGL rally car racing game"
-HOMEPAGE="http://www.positro.net/trigger/"
+HOMEPAGE="http://trigger-rally.sourceforge.net/"
SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.bz2"
LICENSE="GPL-2"
@@ -29,6 +29,8 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+PATCHES=( "${FILESDIR}"/${P}-gcc6.patch )
+
pkg_setup() {
# Otherwise build fails with:
# ...skipped trigger for lack of libpengine.a...