summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/konsolekalendar')
-rw-r--r--kde-apps/konsolekalendar/Manifest1
-rw-r--r--kde-apps/konsolekalendar/konsolekalendar-19.08.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-apps/konsolekalendar/Manifest b/kde-apps/konsolekalendar/Manifest
index 8ff0b149e798..c8417c5559ce 100644
--- a/kde-apps/konsolekalendar/Manifest
+++ b/kde-apps/konsolekalendar/Manifest
@@ -1,2 +1,3 @@
DIST akonadi-calendar-tools-19.04.3.tar.xz 223328 BLAKE2B 47f16a483f49f27d203db3b0627532b7b928f18bead7e22176b340698e7c2e52322139ca92cae9a776b239d9d741656ec3c943eb997c1dd5064da4d818610474 SHA512 d4c61f04861b26fb01b0cd76056fa5107e0257e7b2c118596ed40d87a3cffa8526889bc82b45f9d3cc61d1d4d25518bbeca56edaa028d02f779b7880df2522e5
DIST akonadi-calendar-tools-19.08.2.tar.xz 224508 BLAKE2B 05dcffb5eb960f4bda16075e8f729089390e76b32f0ca6e6ed9a380a69c380ec6796a2a801a04a49a00213cc2891ce3dd01dcb39419f0e13d80bc2b6f0ca0809 SHA512 ff57af694d8fdd6c3bf08c0bdfb58d5cf2e54cccc74fcef1a74321fd1109b2fc0f4a902597fd2461fe91e6e17dd457db50f6b1d22b468afd391175cea0822627
+DIST akonadi-calendar-tools-19.08.3.tar.xz 223564 BLAKE2B e0d9f01659a471307db2c7d8c0906297ec4a880cb0019414520b29a14eee68bf39b02d02dd4e5b3b03c3684022f675f30cdb6efb214adaca64dc27f5eec03c25 SHA512 4cc146da96f6a006749e4c3e0962155fc8bcd788d2ed39adbbe73f1d82bc4264349ce06a9b524ff4fb1a1675e0d66345e5bbad8044360b6fe28d9565672f3922
diff --git a/kde-apps/konsolekalendar/konsolekalendar-19.08.3.ebuild b/kde-apps/konsolekalendar/konsolekalendar-19.08.3.ebuild
new file mode 100644
index 000000000000..d59e0d58720b
--- /dev/null
+++ b/kde-apps/konsolekalendar/konsolekalendar-19.08.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+KDE_ORG_NAME="akonadi-calendar-tools"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.60.0
+inherit ecm kde.org
+
+DESCRIPTION="Command line interface to KDE calendars"
+HOMEPAGE+=" https://userbase.kde.org/KonsoleKalendar"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-calendar-${PVCUT}:5
+ >=kde-apps/calendarsupport-${PVCUT}:5
+ >=kde-apps/kcalutils-${PVCUT}:5
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdepim-l10n
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # delete colliding calendarjanitor translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/calendarjanitor.po || die
+ fi
+
+ cmake_comment_add_subdirectory calendarjanitor
+}