summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/kalzium/files/kalzium-15.12.3-plasmoids.patch23
-rw-r--r--kde-apps/kalzium/kalzium-15.12.3-r2.ebuild47
2 files changed, 70 insertions, 0 deletions
diff --git a/kde-apps/kalzium/files/kalzium-15.12.3-plasmoids.patch b/kde-apps/kalzium/files/kalzium-15.12.3-plasmoids.patch
new file mode 100644
index 000000000000..686a6ef1209a
--- /dev/null
+++ b/kde-apps/kalzium/files/kalzium-15.12.3-plasmoids.patch
@@ -0,0 +1,23 @@
+commit 456205fc98f4eb2762c11fac2abedf618e0deb8f
+Author: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Fri Mar 25 13:38:55 2016 +0100
+
+ Make plasmoids optional
+
+ They are not useable in a Plasma-5 workspace.
+
+ REVIEW: 127491
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f4ab27b..93ae845 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -50,7 +50,7 @@ endif (OPENBABEL2_FOUND AND Avogadro_FOUND AND EIGEN3_FOUND)
+ add_subdirectory(doc)
+ add_subdirectory(src)
+ add_subdirectory(data)
+-add_subdirectory(plasmoid)
++macro_optional_add_subdirectory(plasmoid)
+ add_subdirectory(libscience)
+ add_subdirectory(qml)
+
diff --git a/kde-apps/kalzium/kalzium-15.12.3-r2.ebuild b/kde-apps/kalzium/kalzium-15.12.3-r2.ebuild
new file mode 100644
index 000000000000..30195903c7f5
--- /dev/null
+++ b/kde-apps/kalzium/kalzium-15.12.3-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="always"
+inherit kde4-base flag-o-matic
+
+DESCRIPTION="KDE: periodic table of the elements"
+HOMEPAGE="https://www.kde.org/applications/education/kalzium
+https://edu.kde.org/kalzium"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="debug editor +plasma solver"
+
+DEPEND="
+ editor? (
+ dev-cpp/eigen:3
+ sci-chemistry/avogadro
+ >=sci-chemistry/openbabel-2.2
+ dev-qt/qtopengl:4
+ )
+ solver? ( dev-ml/facile[ocamlopt] )
+"
+RDEPEND="${DEPEND}
+ sci-chemistry/chemical-mime-data
+"
+
+PATCHES=( "${FILESDIR}/${PN}-15.12.3-plasmoids.patch" )
+
+src_configure(){
+ # Fix missing finite()
+ [[ ${CHOST} == *-solaris* ]] && append-cppflags -DHAVE_IEEEFP_H
+
+ local mycmakeargs=(
+ $(cmake-utils_use_build plasma plasmoid)
+ $(cmake-utils_use_with editor Eigen3)
+ $(cmake-utils_use_with editor Avogadro)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)
+ )
+
+ kde4-base_src_configure
+}