summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.7.3.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index 1d9825936c7f..15858f7c6114 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1,3 +1,4 @@
DIST glogo-small.png 24583 SHA256 0afc3eca084c327f8059166b86769f03c9c23e1e765bb47dc3229505abbac0c6 SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48 WHIRLPOOL e161bf40c5e16180fa65217cb49314fb230c45329f4c518d6014083bd71da82d4aa048811ee814fde7fa300105cef16c182688445164ae84d0d700e23641b342
DIST kinfocenter-5.6.5.tar.xz 1409784 SHA256 9425fde6d1f92940a85449d01de6521c963c2ebf7b30b79f31c3f4b8e65629b2 SHA512 4b1692a6b2f1d3aba369463ad5aaa9910906178cf0d447e76366e9c0c4c50bc9de1a850bff149bc4bc52af14a67d68d26cafa5edd1de69e6cdb9995820bc91b8 WHIRLPOOL 340a2e3476a95c5499852f8654f285ca6e46f7d866fa91f62fb6cf7d2ebaea6580871377d81961bd0f11d6f37ebb588fc5b3d586c5e6b12ad7b660dd7ce96b7d
DIST kinfocenter-5.7.2.tar.xz 1154504 SHA256 e4f5ecc296415c7a381df0fd47d167da0b0f2906f3ab876428bbe3e40b88fef6 SHA512 c692188ba9ebfe54919dc2ab97397ddd898e74ad897007120fa2b38735c12cff691207da0bc6513f8ad4175df598c020cab9da0d982a731da0c89dbce8bdc2c7 WHIRLPOOL 17a7bf6e14fd973049bf8732cd40beae7b8838cdc9a1b6e023fab2c11308726128618c3e2ecd03b13f415aa108d19f40fe41722d3c2f97e45d6ef373aa90225d
+DIST kinfocenter-5.7.3.tar.xz 1248856 SHA256 2988a7eea03d701385bf94d2437871440919b851be41f5b4fb3c11380120c6e8 SHA512 cef7ba73b714c4788c00ddf1a8bca4fa9df375dceebb080896273fb5824d50bde6399ab397a278781b2aa32c9abbf9dd2cd9cab37d70e84c672ef8bdf0e132a3 WHIRLPOOL 56389786bd8d8d31b8007fcd19b397f4d3e0277985e21e90e50833c408e14faa999a83ddbabf05d71f23e272ea41b918f1ed8147687e0ccd2d5ed6a1a77ed099
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.7.3.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.7.3.ebuild
new file mode 100644
index 000000000000..cc6f2171f282
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.7.3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="A utility that provides information about a computer system"
+HOMEPAGE="https://www.kde.org/applications/system/kinfocenter/"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="egl gles2 ieee1394 +opengl +pci wayland"
+
+REQUIRED_USE="egl? ( || ( gles2 opengl ) )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ x11-libs/libX11
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ $(add_qt_dep qtgui 'gles2=')
+ media-libs/mesa[egl?,gles2?]
+ !gles2? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ wayland? ( $(add_frameworks_dep kwayland) )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep plasma)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-base/kcontrol:4
+ !kde-base/kinfocenter:4
+ !kde-misc/about-distro
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package egl EGL)
+ $(cmake-utils_use_find_package gles2 OpenGLES)
+ $(cmake-utils_use_find_package ieee1394 RAW1394)
+ $(cmake-utils_use_find_package opengl OpenGL)
+ $(cmake-utils_use_find_package pci PCIUTILS)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if ! has_version "net-fs/nfs-utils"; then
+ einfo "Installing net-fs/nfs-utils will enable the NFS information module."
+ fi
+ if ! has_version "net-fs/samba" || ! has_version "net-fs/samba[server]"; then
+ einfo "Installing net-fs/samba[server(+)] will enable the Samba status information module."
+ fi
+}