summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.23.3.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index e18c347fa536..46d8d5a0e911 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.22.5.tar.xz 24076 BLAKE2B 2625d07b18b5e1ccd98f5b34e402a4ea201190f3be240ea596e8b4c70f0a15204e7d5ea559a0b17bc253247eca41a988f65bb2e29ee07c2e35600d8a1f761b34 SHA512 35f430882aa735f1b9d7a1874f83fa67074cfb720bbba377d0b38baab2f3eaeddc1598f6f7b9c79479b95d22fdc661d7dfd6835b98a78ea159c68d64abc81a67
DIST ksshaskpass-5.23.2.tar.xz 24088 BLAKE2B a416c79e156183d1ebb5c786537132eef0740e0a864910f803b0dac37aca9cd7cb00f3704d9cba7221ce8c52f040c400de5ce508e24ddab74f0ff39e3f54a664 SHA512 c49b9600285f8fb0636ffd0e96b9575883f812b422fc9b680193c92a89917e3ac309d564ca04f484dceb83560afeeea3d1a95b84f51166331fb84cb4aae7f438
+DIST ksshaskpass-5.23.3.tar.xz 24040 BLAKE2B 17db15c4e40cacfd65a1792c9d8992f865b3f0e2237fcfc08405a35f00ec12828c362172c3ec280c47fd3c614597b07f64d6b3e76a91c79f002e00e013a6d2e7 SHA512 0aabdf4e22a70e040bcd5b65fff2f85a43e9727cf53875977f691ae24c9d99a86e2e06df0d92550b9711e0f1623e69cd548c09179909ece232f6f3637cf3f41d
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.23.3.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.23.3.ebuild
new file mode 100644
index 000000000000..618cd3f1026f
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.23.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.86.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Implementation of ssh-askpass with KDE Wallet integration"
+HOMEPAGE+=" https://invent.kde.org/plasma/ksshaskpass"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+
+ insinto /etc/xdg/plasma-workspace/env/
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "In order to have ssh-agent start with Plasma 5,"
+ elog "edit /etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and uncomment the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+ elog "to properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/xdg/plasma-workspace/env/05-ksshaskpass.sh"
+
+ # Clean up pre-5.17.4 dirs
+ rmdir -v "${EROOT}"/etc/plasma{/startup,} 2> /dev/null
+}