summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.8.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index a99bbbc25b41..d806e7438bc6 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,3 +1,4 @@
DIST 50971-ksshaskpass-0.5.3.tar.gz 11010 SHA256 a3a47eba74a52ec3d9d8740ed9a29a5aa852d4e268b5d81154f85b90258a2124 SHA512 0274b58fb9dbb634688e5ee8b22a88012483907769796733c79f8e3c115463702a9cdd787d49d0b94a7942f5f88ed3465a6161d6e4516711b2bba5c47a91fa50 WHIRLPOOL d3e68640d3e0049bdd071fe72bf0bd9767bf349c94b2fbb42e7fafe6259d895ec2d5122ae9477e66073c53cbbda704ec0237328dd948b21207b2db2b39946450
DIST ksshaskpass-5.7.5.tar.xz 19232 SHA256 967288a9ba7b007dfdc540db00b3b9ab44c4195630144f26b1fc5b780dd00939 SHA512 4ba4d865e51e8e8ec416b3b164bfb46f0e44423b7abdeb6360cfbd9b2f743dd76664f9844120e102f575d5b0babad20a36846b94e921db43ea414ecc08fe43ec WHIRLPOOL ca55d956678b73e803e0463c82740e8b10314c598ca6a394b8b436155f6d0b36a0ca79e72d9016f4e55639b8ef328362678567fab2adce3ef16ff9f573938697
DIST ksshaskpass-5.8.2.tar.xz 19248 SHA256 7a00622a12993d14d68e3def143a4291e32cef766e3e0b976e969e4c799668f2 SHA512 e6378bb28dd613f5bf8c2f2c8a845d0735c1924b3324f7be512970cf4da57fa81a2b485f6cad7e9e04779fbb3e1e95990a4bf3bfe212876cca6605c4fa398446 WHIRLPOOL edddda966ca11f7e27ebfcd33b4209c9b6ccb06d17a9a0cc6dc37cfe8d576d267ffd8ffda15ec9d117469c1bbae1b8aecdf4187ce6b16632230a0e88d4af3b34
+DIST ksshaskpass-5.8.3.tar.xz 19252 SHA256 72de4eb6adaadef5e4d30f10c22bd0aef1d5197070589f54d03b7983d7b76e4f SHA512 21d4650e841333bfb6093c4614c80c3e848be1da8f1cdaf0ba3525ac72ea75f31c10043daa1bda250203fa42726928e7103b8a5082d53aa02032fdb314d7b9f3 WHIRLPOOL 9c0ae0fdd09fae5a6aa8118253994fcd72b91efa5fc42a47f1c9ce4c4c68219ffdfaeb912dc835a8504c0a613b8b66da0bb14ffac091559c1081c880d8466e07
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.8.3.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.8.3.ebuild
new file mode 100644
index 000000000000..4fed5b5ec2c5
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.8.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://projects.kde.org/projects/kde/workspace/ksshaskpass"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="
+ ${DEPEND}
+ !kde-plasma/ksshaskpass:4
+"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}