summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.9.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index d6623561cdd7..dfb9ed6eb952 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,3 +1,4 @@
DIST ksshaskpass-5.8.5.tar.xz 19456 SHA256 b0abeaba2a3eff16e233e047b41c20bf4065b4529e706929f4c0e6a9884324bf SHA512 0ab10f04fea8d97bb7e942cfd11563d22e065e19414aad2484e5b1661ed7b492d769da69b30eeed9e392ef75a3cc518e0a8005fe5afb84dfc6192ad9a4c0bc8b WHIRLPOOL 19c08e63ef15f0e5a38cc10d02f71e3bb616ec7d219f06cf1004af9789832a6e2a031548ef78790f67a46bf5e69b076dc2d7082ba25b6c39621eaa97a9113546
DIST ksshaskpass-5.8.6.tar.xz 19460 SHA256 0f195e6344b17cacb8ee0499c36f911970edd968b6dbbc008ccff4b659132179 SHA512 7d2918b95f14f41dc1b348a66a39f2d739c01e8061136aa97f27612c18fe85f779dcff7df82c22450869f31c94f71e3f5eae743cb976c0e6e6d0692db2dc450d WHIRLPOOL 5237e9409904382cf79e8caae65c2b6d730141d04acd2e643c5ac7aac04d9707a0a459a343f1c485ccb10a7abf36a90f5bbbe47ab73d1796fd03fd5ffcc5dc33
DIST ksshaskpass-5.9.2.tar.xz 20072 SHA256 e4ca4282814da54595919f617cea3050a8e266d1cb8b83e05f26c84b5e3c209e SHA512 b43bb41aecf781b8dc8008dc0a7b4803b536c05ef9283a497fe36b0c435b162abe7208a23276c8cb42b524e8e7817833d513c8ace9a2d519d9630a143a9e583b WHIRLPOOL 86bed00de405a5f4d9533b8644affa9bb435b6fdd7976341178de315b7e27bab19b5515c0d728713c2878c2560afe1b64365fa4acda218b2a2490e9c699d4e4f
+DIST ksshaskpass-5.9.3.tar.xz 20060 SHA256 1c0ab2d4550ba860a492f8b2930283a59d3261ac1797480795122b615799664a SHA512 9a6a9bb918a86fbd9c3e8ded0482d51c7ca81897d822cb9250a4e5cc322902d579c59b089dc9344a9d0727a25d619f6d67250589b2e56b47e8c91ff614e41dee WHIRLPOOL e38c3861ec487436e9f231dc099901581df8904e56108b6031deca502f9201bbcbef36ebaeb6b293e4454602e0872aec866e2c402213f801d875f2c4c569a028
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.9.3.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.9.3.ebuild
new file mode 100644
index 000000000000..468b1b597c06
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.9.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://projects.kde.org/projects/kde/workspace/ksshaskpass"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="
+ ${DEPEND}
+ !kde-plasma/ksshaskpass:4
+"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}