summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/ksshaskpass')
-rw-r--r--kde-plasma/ksshaskpass/Manifest1
-rw-r--r--kde-plasma/ksshaskpass/ksshaskpass-5.12.3.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/kde-plasma/ksshaskpass/Manifest b/kde-plasma/ksshaskpass/Manifest
index 81861ba9bfc4..b1c47a47afc6 100644
--- a/kde-plasma/ksshaskpass/Manifest
+++ b/kde-plasma/ksshaskpass/Manifest
@@ -1,2 +1,3 @@
DIST ksshaskpass-5.11.5.tar.xz 23168 BLAKE2B 74d10be7c303d0b7d1d8765e08a89986b4c1745e5f601982dd406cefc7c73ac684c1c05acdd355d45f5078e034ab9971467b4b76c0ae3a94800ce6480fa8c3f0 SHA512 34a8fe5da983a0fcc6d5d223120f2d23e0168a534d29941e83024110eafe981d6c46ee503abfb7bf8e072dc64060eea373c191ef0f8dbc5051cb2d968e6d49d3
DIST ksshaskpass-5.12.2.tar.xz 21228 BLAKE2B 7e08ae4f5450084b5ed4bc22ac84a48a40f2a407f83976682553a2f05914c217f00003b5ad8004111a82f15559b3d556f9e4f336783401fc0cec5ddafa4bcf2b SHA512 0e1d82698b791ddcfac5ccf9781455b45d61f3c0b8ab0b9de46392ce1a8d31cc687b5243e334823eae690f2509ddbe60c6ab00f5c34593fec9c1625d03ab9858
+DIST ksshaskpass-5.12.3.tar.xz 21172 BLAKE2B 93aa3a8c9aa0d332004c1864fb9255438461aa5d2a2a279541279b978794cffbfc3ab8367f9ea7115503ebedf65461fd3b2997e3cd684fd4bf20d0cd03dbadb9 SHA512 edeeb3b4e47dc29c7681eaaa7a3f7ba0d68076e86a03c42241aed5420c5cc87000c410816987e7c033b275c6001f4083f05f31bbef79f08481479362ec8b97fe
diff --git a/kde-plasma/ksshaskpass/ksshaskpass-5.12.3.ebuild b/kde-plasma/ksshaskpass/ksshaskpass-5.12.3.ebuild
new file mode 100644
index 000000000000..3009c8d5ff69
--- /dev/null
+++ b/kde-plasma/ksshaskpass/ksshaskpass-5.12.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE implementation of ssh-askpass with Kwallet integration"
+HOMEPAGE="https://cgit.kde.org/ksshaskpass.git"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtwidgets)
+"
+RDEPEND="
+ ${DEPEND}
+ !kde-plasma/ksshaskpass:4
+"
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/plasma/startup
+ doins "${FILESDIR}/05-ksshaskpass.sh"
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ elog ""
+ elog "In order to have ssh-agent start at kde startup,"
+ elog "edit /etc/plasma/startup/10-agent-startup.sh and uncomment"
+ elog "the lines enabling ssh-agent."
+ elog
+ elog "If you do so, do not forget to uncomment the respective"
+ elog "lines in /etc/plasma/shutdown/10-agent-shutdown.sh to"
+ elog "properly kill the agent when the session ends."
+ elog
+ elog "${PN} has been installed as your default askpass application"
+ elog "for Plasma 5 sessions."
+ elog "If that's not desired, select the one you want to use in"
+ elog "/etc/plasma/startup/05-ksshaskpass.sh"
+ elog ""
+}