summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/ksysguard')
-rw-r--r--kde-plasma/ksysguard/Manifest1
-rw-r--r--kde-plasma/ksysguard/ksysguard-5.12.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/kde-plasma/ksysguard/Manifest b/kde-plasma/ksysguard/Manifest
index 8b8e73869523..f29e47cacc08 100644
--- a/kde-plasma/ksysguard/Manifest
+++ b/kde-plasma/ksysguard/Manifest
@@ -1 +1,2 @@
DIST ksysguard-5.11.5.tar.xz 502228 BLAKE2B 49e82c26ea1c032e8e036e509c6a46c5da409f4092679a623bc26342f34ffa90d96306fb5638b1fe5a4edafe6f48af6ee12876286788b11145c00c1a32765edb SHA512 62af21b0d911abac5b66ccddeb0180c08199c0cfd8807d461fcfe444105ce7912efb5b8286e7f4955e97cb537edc32f046d646e82ecfc2d61ec39b2a53ed4d93
+DIST ksysguard-5.12.0.tar.xz 487248 BLAKE2B 46ca521c6149e1b2a5baffbd9248ac2f90c8b58b67b095936b5fb59399b1b4b9411fd0391e75cc1e93a57dfb1b1ec0def1a344375998caf30facad0ad1b5ae5d SHA512 d660b01d190860e42b4f21c420d6eb91da5f8cf35f658ecb13f19e86136070c14cba3c9ac13338c6586aee3ef5e8363c8e65597a7ecee2c5b88356ead292b9d9
diff --git a/kde-plasma/ksysguard/ksysguard-5.12.0.ebuild b/kde-plasma/ksysguard/ksysguard-5.12.0.ebuild
new file mode 100644
index 000000000000..5e2260a85627
--- /dev/null
+++ b/kde-plasma/ksysguard/ksysguard-5.12.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Network-enabled task manager and system monitor"
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="lm_sensors"
+
+DEPEND="
+ $(add_plasma_dep libksysguard '-minimal(-)')
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+RDEPEND="${DEPEND}
+ !kde-plasma/ksysguard:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package lm_sensors Sensors)
+ )
+
+ kde5_src_configure
+}