summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.11.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 6a0878fb8ce4..8181640fbf6e 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1 +1,2 @@
DIST kwallet-pam-5.10.5.tar.xz 17908 SHA256 c42e444c9c85dc5bbc60bbd666d20ea72162ddd38dc18254c47c48a0ca404073 SHA512 7a2e1a0a85ffc7d9dfd6a1dc8a16d7117f30fc3b983756e28fc11a19bddf99a273842a1774ccf93c5c879a1d899212f6b6d0808fa14eb17260396f5c207e3dc5 WHIRLPOOL d0db78bc52855b700242079d423fbdb1089796f40be994ad1b9109570e7be46eada006ea62dda8181afdf52f834510121b6fc00c1af3e36bbff7512a32e463f0
+DIST kwallet-pam-5.11.0.tar.xz 18588 SHA256 f278b63606168bbfd97658834b59a88465549ffb52607bce73449005a3fb62eb SHA512 6fa2e98d16b04ee1f843b33d2b5044824f3c9c52f85a5d088879751f16420c9e4aef86ff4d6649903edcb75edf7f60d89c3f3af9419addde52fa7dc761fefdbb WHIRLPOOL 9ed2d2b9dc1bcd5fd3036608ea8934f5d46a9c142da99d48c53928e6070fdff3e498bbe21fe95b441ba496ac352742d3f6e4139345425f3651ce2939fa114e91
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.11.0.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.11.0.ebuild
new file mode 100644
index 000000000000..c91205f1557b
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.11.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KWallet PAM module to not enter password again"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ virtual/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ -DKWALLET4=0
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ check_dm() {
+ if [[ -e "${ROOT}${2}" ]] ; then
+ if grep -Eq "auth\s+optional\s+pam_kwallet5.so" "${ROOT}${2}" && \
+ grep -Eq "session\s+optional\s+pam_kwallet5.so" "${ROOT}${2}" ; then
+ elog " ${1} - ${2} ...GOOD"
+ else
+ ewarn " ${1} - ${2} ...BAD"
+ fi
+ fi
+ }
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "List of things to make it work:"
+ elog "1. Use standard blowfish encryption instead of GPG"
+ elog "2. Use same password for login and kwallet"
+ elog "3. A display manager with support for PAM"
+ elog "4.a Have the following lines in the display manager's pam.d file:"
+ elog " -auth optional pam_kwallet5.so"
+ elog " -session optional pam_kwallet5.so auto_start"
+ elog "4.b Checking installed DMs..."
+ has_version "x11-misc/sddm" && check_dm "SDDM" "/etc/pam.d/sddm"
+ has_version "x11-misc/lightdm" && check_dm "LightDM" "/etc/pam.d/lightdm"
+ elog
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}