summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest2
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.24.6.ebuild37
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.25.4.ebuild37
-rw-r--r--kde-plasma/kwallet-pam/metadata.xml11
4 files changed, 87 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
new file mode 100644
index 000000000000..684492c70fdc
--- /dev/null
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -0,0 +1,2 @@
+DIST kwallet-pam-5.24.6.tar.xz 20472 BLAKE2B 3b389214d21c4f76aac3569e39e4e8babaaef3c21c3a930d89b2d3c941adc201bfe6fa6c7417d9c46c32a1988828f55c4771c02a88544c95033fc5144c082886 SHA512 99eb5e2a003062e2facc40953cd6121c8752b04cf928a7d1302ec9007e1108f61ae52e906950c5caff2c6fe4d333e3b174a3db0f858bbb6aa24016533a84bbfc
+DIST kwallet-pam-5.25.4.tar.xz 20572 BLAKE2B 8ae09e700cbd0859f26017f446945b6e8c9c4c389bcee8cbea5a9b2401716e8b6a247b602b4e5ad8a39aa3ba9fc9d05bb8055ceb2f5985b2d8d169cdac968a10 SHA512 ea7daa8391a2f032490ae1e91d4a7457258eeedc1effdaadc83590febbb02644a309790fdc51c2ce6704ac74e781a8a4b00e16d0d959d8803f7005b521d65ab9
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.24.6.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.24.6.ebuild
new file mode 100644
index 000000000000..3944c07a37dc
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.24.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.92.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm plasma.kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.25.4.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.25.4.ebuild
new file mode 100644
index 000000000000..f7395b5d047c
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.25.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.95.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm plasma.kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}
diff --git a/kde-plasma/kwallet-pam/metadata.xml b/kde-plasma/kwallet-pam/metadata.xml
new file mode 100644
index 000000000000..d925f2439758
--- /dev/null
+++ b/kde-plasma/kwallet-pam/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://bugs.kde.org/</bugs-to>
+ </upstream>
+</pkgmetadata>