summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/oxygen-fonts/oxygen-fonts-5.3.2.ebuild')
-rw-r--r--kde-plasma/oxygen-fonts/oxygen-fonts-5.3.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-plasma/oxygen-fonts/oxygen-fonts-5.3.2.ebuild b/kde-plasma/oxygen-fonts/oxygen-fonts-5.3.2.ebuild
new file mode 100644
index 000000000000..fd95230a7414
--- /dev/null
+++ b/kde-plasma/oxygen-fonts/oxygen-fonts-5.3.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_AUTODEPS="false"
+KDE_DEBUG="false"
+inherit kde5 font
+
+DESCRIPTION="Desktop/GUI font family for integrated use with the KDE desktop"
+HOMEPAGE="https://projects.kde.org/projects/kde/workspace/oxygen-fonts"
+
+LICENSE="OFL-1.1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep extra-cmake-modules)
+ media-gfx/fontforge
+"
+RDEPEND="!media-fonts/oxygen-fonts"
+
+DOCS=( README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DOXYGEN_FONT_INSTALL_DIR="${FONTDIR}"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ font_src_install
+}