summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.6.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 49e488b64998..0644ee5d5eb6 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1 +1,2 @@
DIST plasma-integration-5.6.1.tar.xz 51196 SHA256 8ac0ce54a0ea4c603d7985a11ba93cb35476aa3aa74268f69d077859729e28a0 SHA512 6d4dd692a4b512e4378de8cc60ea233d30e708bd7e4ec34267ad6ba350f16c52dd6e2cc7a1b9ce8dd9e4dee10d6ed11702677beb468a1182aff5a8cd440ed9ee WHIRLPOOL ee46d863185475bb0c71f41961c1a9762943c6537830f98b00112f5eb92c62ae6a8c9fa37fd47b207b6c5a8f1a18e484c7fd42f93741d3006b658eccbdbf8d3b
+DIST plasma-integration-5.6.2.tar.xz 51188 SHA256 429ddc48da319652323bca842d8350248ce6dfd6eb4d4bad5c4b97289754f347 SHA512 da444d5645c30633728946b1c1977b2720887c8487200ff52cdb8855558d52195383f09257b4b28a45cbd7063d6b678e875047836402fb285c87950458d9bbf0 WHIRLPOOL bcdf5027b74e1c563a5c4efcf6a9b00fa602002606d40671eef4f4cef6f2c3326617951fea460034b070f2139ee5895142a24ede3cb2198f2f2223ec031e6b45
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.6.2.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.6.2.ebuild
new file mode 100644
index 000000000000..e124da2aaa23
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.6.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep kwayland)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui '' '' '5=')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep oxygen-fonts '' 5.4.3)
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT="test"