summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-integration')
-rw-r--r--kde-plasma/plasma-integration/Manifest1
-rw-r--r--kde-plasma/plasma-integration/plasma-integration-5.10.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-plasma/plasma-integration/Manifest b/kde-plasma/plasma-integration/Manifest
index 69ce562269a0..219567a97a2d 100644
--- a/kde-plasma/plasma-integration/Manifest
+++ b/kde-plasma/plasma-integration/Manifest
@@ -1,3 +1,4 @@
+DIST plasma-integration-5.10.1.tar.xz 51336 SHA256 7b1318a470d075e97c1faf7870dfc0c8297862ae96ed65b11aa2791558b58316 SHA512 30209ce295fd2c6c8febcdfca131cf7a1e4a4f431d5b18dbf83ee13d2132e6991518418a2d0287bec03b84b754aeda490e20ffe5feb1569fb1b2a9e5001b83ca WHIRLPOOL 4f3e0e3a26586f332a6ac902fb572095c283dd2efa0b6a2c573b48dec383bd621b76f174ff1bddf89fd2ac9800aa8234cf1a193b5b6f95f9e910490b9bfa5d23
DIST plasma-integration-5.8.6.tar.xz 51160 SHA256 ccb22bc771940ec9b6ef7a742af18b8b456ccc05b50b1d29b8b9ecde4b8a076c SHA512 8046549ebd6f0085779de0cd4d85c79d1c03109925b87a3e6466909c006321dca658f95f82cd573cff5403662d47e067765b976221dc2f6172ad2f163973553e WHIRLPOOL b9398ee52dc4c73d373bcabc270a821627594cb0d934b0b3803a9f32e22dc1e16dad53d56720fc026c8e6fabde9ee1a36023dec2822e1b9eff6d38081e971b32
DIST plasma-integration-5.8.7.tar.xz 51024 SHA256 1584cb3977abc3b8ec9acad2fffd5b701dc370b308b5bf86b7547afab76707e7 SHA512 04e4528a59f916d9fed8d083b699711df62a504aada40b71607fa10fd51074aae63b163eca2c4893fc07bf86718a567a9047b61874da6eea282993e25bf5c919 WHIRLPOOL 8f617718c0fd1ddca89e9842a020f00602a34b52653a14a00011b2d92be892a2f4b01d5687f47715d6771e52a3e1587ec4e2ae9664dbfc2c8c154d84636dfd67
DIST plasma-integration-5.9.5.tar.xz 49688 SHA256 1c84fdf4bd2d285485d0703248d3ae502443737f0cbc9870171560e872ce1d17 SHA512 5e69fb375b83cdc28230b9f1ff4a09ae2cdae3614ba2b7ab971d3d1666616eb7444c68e0065be927e8616c08a773f0b36ed9913f61066094a7a65f65174a8988 WHIRLPOOL 3d3a705ca1f00de7ed152adc6aed9d100b175027d0c874a40e521bf97a78a4f13c8d779235c6b86796f8f13a3516a8c31f02bdcdb5609019f038f385528fcb69
diff --git a/kde-plasma/plasma-integration/plasma-integration-5.10.1.ebuild b/kde-plasma/plasma-integration/plasma-integration-5.10.1.ebuild
new file mode 100644
index 000000000000..e50dd6194fb0
--- /dev/null
+++ b/kde-plasma/plasma-integration/plasma-integration-5.10.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Qt Platform Theme integration plugins for the Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_plasma_dep breeze)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui 'dbus' '' '5=')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libXcursor
+ x11-libs/libxcb
+"
+RDEPEND="${DEPEND}
+ media-fonts/hack
+ media-fonts/noto
+"
+
+# requires running kde environment
+RESTRICT+=" test"