summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-nm')
-rw-r--r--kde-plasma/plasma-nm/Manifest1
-rw-r--r--kde-plasma/plasma-nm/plasma-nm-5.12.2.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/kde-plasma/plasma-nm/Manifest b/kde-plasma/plasma-nm/Manifest
index 13d868ad53cc..f811b1766dcb 100644
--- a/kde-plasma/plasma-nm/Manifest
+++ b/kde-plasma/plasma-nm/Manifest
@@ -1,2 +1,3 @@
DIST plasma-nm-5.11.5.tar.xz 718500 BLAKE2B bdd9520cfa3a305f7f2c271fdfc9678b43ed46e160ff7c7485a963889b32e60f56408bcc39b4fce81e570ce194410730a628bb2eb96afcfba8704b787d90c05a SHA512 6bc42e9b385fff03d994d66fb2088ce22b2766588c655466e4e26a0b57f1533c142ce7712c9182d9003368f30086333ea9670bac54b9b797e58a968f8bfc3512
DIST plasma-nm-5.12.1.tar.xz 703312 BLAKE2B 5a29f4824afbd59824f7ccb15c4ce77713f83b86bbebcbef6167c6dda6e040c1cc4a0c4dfbedc6596ae37105449f5f6d99e328478d5101d29362584c494a95cb SHA512 a35ef52235116cf815aa92ca8c66f2756d31295d940d8279fa032d5f3815b4b376970577a0df2b14e8d30efb9db08b571433ad32cbaf845961c3f501c0e9ef6c
+DIST plasma-nm-5.12.2.tar.xz 705400 BLAKE2B 8c2b28fcee43a32838432656b652369587c99613ee4dc6be87dad23e9384d1a11234650314716231cea2f938e17358d5321758ce370b08684636e465c138a4cf SHA512 080a9d11bc3a8665518a99f560d93d36e3ff80a0231d1e501bc1f450b01b784818b2935cc0542c20aed175938b0f9f233117e5d5aa98634c81411ccaf2cbb0df
diff --git a/kde-plasma/plasma-nm/plasma-nm-5.12.2.ebuild b/kde-plasma/plasma-nm/plasma-nm-5.12.2.ebuild
new file mode 100644
index 000000000000..3d76b41d85c4
--- /dev/null
+++ b/kde-plasma/plasma-nm/plasma-nm-5.12.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="KDE Plasma applet for NetworkManager"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="modemmanager openconnect teamd"
+
+DEPEND="
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep networkmanager-qt 'teamd=')
+ $(add_frameworks_dep plasma)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ >=app-crypt/qca-2.1.1:2[qt5]
+ >=net-misc/networkmanager-0.9.10.0[teamd=]
+ modemmanager? (
+ $(add_frameworks_dep modemmanager-qt)
+ $(add_qt_dep qtxml)
+ net-misc/mobile-broadband-provider-info
+ )
+ openconnect? (
+ $(add_qt_dep qtxml)
+ net-misc/networkmanager-openconnect
+ net-vpn/openconnect:=
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-plasma/plasma-nm:4
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package modemmanager ModemManager)
+ $(cmake-utils_use_find_package modemmanager KF5ModemManagerQt)
+ $(cmake-utils_use_find_package openconnect OpenConnect)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-plasma/plasma-workspace:5"; then
+ einfo "${PN} is not terribly useful without kde-plasma/plasma-workspace:5."
+ einfo "However, the networkmanagement KCM can be called from either systemsettings"
+ einfo "or manually: $ kcmshell5 kcm_networkmanagement"
+ fi
+}