summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-filter/gld')
-rw-r--r--mail-filter/gld/gld-1.7-r4.ebuild (renamed from mail-filter/gld/gld-1.7-r3.ebuild)29
1 files changed, 17 insertions, 12 deletions
diff --git a/mail-filter/gld/gld-1.7-r3.ebuild b/mail-filter/gld/gld-1.7-r4.ebuild
index 90926c4222af..c367f5ee96a7 100644
--- a/mail-filter/gld/gld-1.7-r3.ebuild
+++ b/mail-filter/gld/gld-1.7-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="7"
inherit toolchain-funcs
@@ -17,7 +17,7 @@ IUSE="libressl postgres"
DEPEND="sys-libs/zlib
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl )
- !postgres? ( virtual/mysql )
+ !postgres? ( dev-db/mysql-connector-c:0= )
postgres? ( dev-db/postgresql:*[server] )"
RDEPEND="${DEPEND}"
@@ -37,17 +37,19 @@ src_prepare() {
sed -i tables.{my,pg}sql \
-e '/ip char/s/16/39/' \
|| die "sed sql tables failed"
+
+ sed -i configure \
+ -e "/SQL_LIBS/{s~/lib~/$(get_libdir)~g}" || die
+
+ default
}
src_configure() {
tc-export CC
+
# It's kind of weird. $(use_with postgres pgsql) won't work if you don't
# use it...
- if use postgres ; then
- myconf="${myconf} --with-pgsql"
- fi
-
- econf ${myconf}
+ econf $(usex postgres '--with-pgsql' '')
}
src_install() {
@@ -69,9 +71,12 @@ pkg_preinst() {
elog "details on how to setup gld."
elog
elog "The sql files have been installed to /usr/share/${PN}/sql."
- if [[ $REPLACING_VERSIONS == "1.7-r1" ]]; then
- elog "You might want to use the ALTER_TABLE command to change the"
- elog "ip field width to 39 chars to accomodate ipv6 addresses."
- elog "Please see your sql server documentation."
- fi
+ local old_ver
+ for old_ver in ${REPLACING_VERSIONS} ; do
+ if ver_test ${old_ver} -eq "1.7-r1" ; then
+ elog "You might want to use the ALTER_TABLE command to change the"
+ elog "ip field width to 39 chars to accomodate ipv6 addresses."
+ elog "Please see your sql server documentation."
+ fi
+ done
}