summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-fonts/khmer/khmer-5.0-r1.ebuild')
-rw-r--r--media-fonts/khmer/khmer-5.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-fonts/khmer/khmer-5.0-r1.ebuild b/media-fonts/khmer/khmer-5.0-r1.ebuild
new file mode 100644
index 000000000000..9c66dd767b04
--- /dev/null
+++ b/media-fonts/khmer/khmer-5.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit font
+
+DESCRIPTION="Fonts for the Khmer language of Cambodia"
+HOMEPAGE="http://www.khmeros.info/drupal/?q=en/download/fonts"
+SRC_URI="mirror://sourceforge/khmer/All_KhmerOS_${PV}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/All_KhmerOS_${PV}"
+FONT_S="${S}"
+FONT_SUFFIX="ttf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ [[ -f "KhmerOS .ttf" ]] && mv "KhmerOS .ttf" "KhmerOS.ttf" # 338057
+}
+
+pkg_postinst() {
+ font_pkg_postinst
+ echo
+ elog "To prefer using Khmer OS fonts, run:"
+ elog
+ elog " eselect fontconfig enable 65-khmer.conf"
+ echo
+}