summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/album/album-4.07.ebuild')
-rw-r--r--media-gfx/album/album-4.07.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-gfx/album/album-4.07.ebuild b/media-gfx/album/album-4.07.ebuild
new file mode 100644
index 000000000000..9e47e43e94cd
--- /dev/null
+++ b/media-gfx/album/album-4.07.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="HTML photo album generator"
+HOMEPAGE="http://MarginalHacks.com/Hacks/album/"
+SRC_URI="http://marginalhacks.com/bin/album.versions/${P}.tar.gz
+ http://marginalhacks.com/bin/album.versions/data-4.05.tar.gz"
+
+LICENSE="marginalhacks"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="doc ffmpeg plugins themes"
+
+DEPEND=""
+RDEPEND="dev-lang/perl
+ media-gfx/imagemagick
+ media-gfx/jhead
+ ffmpeg? ( virtual/ffmpeg )"
+
+src_install() {
+ dobin album
+ doman album.1
+ dodoc License.txt CHANGELOG
+ use doc && dohtml -r Docs/*
+
+ dodir /usr/share/album
+ insinto /usr/share/album
+ cd ..
+ doins -r lang
+ use themes && doins -r Themes
+ use plugins && doins -r plugins
+}
+
+pkg_postinst() {
+ elog "For some optional tools please browse:"
+ elog "http://MarginalHacks.com/Hacks/album/tools/"
+}