summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/cairosvg/cairosvg-1.0.7.ebuild')
-rw-r--r--media-gfx/cairosvg/cairosvg-1.0.7.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-gfx/cairosvg/cairosvg-1.0.7.ebuild b/media-gfx/cairosvg/cairosvg-1.0.7.ebuild
new file mode 100644
index 000000000000..84daf3f84cd9
--- /dev/null
+++ b/media-gfx/cairosvg/cairosvg-1.0.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="CairoSVG"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A simple cairo based SVG converter with support for PDF, PostScript and PNG formats"
+HOMEPAGE="http://cairosvg.org/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/tinycss[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/cairocffi[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( NEWS.rst README.rst TODO.rst )