summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/crwinfo/crwinfo-0.2.ebuild')
-rw-r--r--media-gfx/crwinfo/crwinfo-0.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-gfx/crwinfo/crwinfo-0.2.ebuild b/media-gfx/crwinfo/crwinfo-0.2.ebuild
new file mode 100644
index 000000000000..a70c54a3af57
--- /dev/null
+++ b/media-gfx/crwinfo/crwinfo-0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Canon raw image (CRW) information and thumbnail extractor"
+HOMEPAGE="http://freshmeat.net/projects/crwinfo/"
+SRC_URI="http://neuemuenze.heim1.tu-clausthal.de/~sven/crwinfo/CRWInfo-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc amd64 alpha ia64 hppa ppc64"
+IUSE=""
+
+S="${WORKDIR}/CRWInfo-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}.patch
+ sed \
+ -e '/gcc/s:^.*$:\t$(CC) $(CFLAGS) -Wall -c crwinfo.c\n\t$(CC) $(LDFLAGS) -o crwinfo crwinfo.o:g' \
+ -i Makefile || die
+ tc-export CC
+}
+
+src_install() {
+ dobin crwinfo
+ dodoc README spec
+}