summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/fontypython/fontypython-0.4.4-r1.ebuild')
-rw-r--r--media-gfx/fontypython/fontypython-0.4.4-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-gfx/fontypython/fontypython-0.4.4-r1.ebuild b/media-gfx/fontypython/fontypython-0.4.4-r1.ebuild
new file mode 100644
index 000000000000..3e257dabe2b0
--- /dev/null
+++ b/media-gfx/fontypython/fontypython-0.4.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython 2.7-pypy-*"
+
+inherit distutils eutils multilib python
+
+DESCRIPTION="Font preview application"
+HOMEPAGE="http://savannah.nongnu.org/projects/fontypython"
+SRC_URI="http://download.savannah.nongnu.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+# Crashes w/ debug build of wxGTK (#201315)
+DEPEND="dev-python/pillow
+ dev-python/wxpython:2.8
+ x11-libs/wxGTK:2.8[-debug]"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="fontypythonmodules"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-pillow.patch"
+}
+
+src_install() {
+ distutils_src_install
+ doman "${S}"/fontypython.1
+}