summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gif2apng/gif2apng-1.6.ebuild')
-rw-r--r--media-gfx/gif2apng/gif2apng-1.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-gfx/gif2apng/gif2apng-1.6.ebuild b/media-gfx/gif2apng/gif2apng-1.6.ebuild
new file mode 100644
index 000000000000..02c481d62692
--- /dev/null
+++ b/media-gfx/gif2apng/gif2apng-1.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="create an APNG from a GIF"
+HOMEPAGE="http://sourceforge.net/projects/gif2apng/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS="-lz" ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}