summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gliv/gliv-1.9.6.ebuild')
-rw-r--r--media-gfx/gliv/gliv-1.9.6.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/media-gfx/gliv/gliv-1.9.6.ebuild b/media-gfx/gliv/gliv-1.9.6.ebuild
new file mode 100644
index 000000000000..7dc18066a73f
--- /dev/null
+++ b/media-gfx/gliv/gliv-1.9.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit eutils autotools
+
+DESCRIPTION="An image viewer that uses OpenGL"
+HOMEPAGE="http://guichaz.free.fr/gliv/"
+SRC_URI="http://guichaz.free.fr/gliv/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2.6:2
+ virtual/opengl
+ >x11-libs/gtkglext-1.0.6
+ nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/bison-1.875"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls)
+}
+
+src_install() {
+ # Needed if desktop-file-install is present, else we get
+ # sandbox violations.
+ export DESKTOP_FILE_INSTALL_DIR="${D}/usr/share/applications"
+
+ einstall || die "make install failed"
+ dodoc README NEWS THANKS
+}