summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gqview/gqview-2.1.5-r1.ebuild')
-rw-r--r--media-gfx/gqview/gqview-2.1.5-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-gfx/gqview/gqview-2.1.5-r1.ebuild b/media-gfx/gqview/gqview-2.1.5-r1.ebuild
new file mode 100644
index 000000000000..a57d74d5772c
--- /dev/null
+++ b/media-gfx/gqview/gqview-2.1.5-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="A GTK-based image browser"
+HOMEPAGE="http://gqview.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gqview/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ppc ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.4:2
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-windows.patch" \
+ "${FILESDIR}/${P}-glibc.patch"
+ sed -i \
+ -e '/^Encoding/d' \
+ -e '/^Icon/s/\.png//' \
+ -e '/^Categories/s/Application;//' \
+ gqview.desktop || die
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --without-lcms
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ # leave README uncompressed because the program reads it
+ dodoc AUTHORS ChangeLog TODO
+ rm -f "${D}/usr/share/doc/${PF}/COPYING"
+}