summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/mandelbulber/files/mandelbulber-1.21.1-qa.patch')
-rw-r--r--media-gfx/mandelbulber/files/mandelbulber-1.21.1-qa.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/mandelbulber/files/mandelbulber-1.21.1-qa.patch b/media-gfx/mandelbulber/files/mandelbulber-1.21.1-qa.patch
new file mode 100644
index 000000000000..6fea9525cfe1
--- /dev/null
+++ b/media-gfx/mandelbulber/files/mandelbulber-1.21.1-qa.patch
@@ -0,0 +1,30 @@
+--- mandelbulber1.21-1.orig/makefiles/makefile
++++ mandelbulber1.21-1.orig/makefiles/makefile
+@@ -5,6 +5,7 @@
+ -include ../makefile.init
+
+ RM := rm -rf
++CXX ?= g++
+
+ # All of the sources participating in the build are defined here
+ -include sources.mk
+@@ -44,7 +45,7 @@
+ mandelbulber: $(OBJS) $(USER_OBJS)
+ @echo 'Building target: $@'
+ @echo 'Invoking: GCC C++ Linker'
+- g++ -o"mandelbulber" -L/usr/lib/x86_64-linux-gnu/ $(CXXFLAGS) $(CPPFLAGS) $(LDFLAGS) $(OBJS) $(USER_OBJS) $(LIBS)
++ $(CXX) -o"mandelbulber" -L/usr/lib/x86_64-linux-gnu/ $(CXXFLAGS) $(CPPFLAGS) $(LDFLAGS) $(OBJS) $(USER_OBJS) $(LIBS)
+ @echo 'Finished building target: $@'
+ @echo ' '
+
+--- mandelbulber1.21-1.orig/makefiles/src/subdir.mk
++++ mandelbulber1.21-1.orig/makefiles/src/subdir.mk
+@@ -71,7 +71,7 @@
+ src/%.o: ../src/%.cpp
+ @echo 'Building file: $<'
+ @echo 'Invoking: GCC C++ Compiler'
+- g++ -O3 -ffast-math -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" $(CXXFLAGS) $(CPPFLAGS) -o"$@" "$<"
++ $(CXX) -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" $(CXXFLAGS) $(CPPFLAGS) -o"$@" "$<"
+ @echo 'Finished building: $<'
+ @echo ' '
+