summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pdf2svg/pdf2svg-0.2.1.ebuild')
-rw-r--r--media-gfx/pdf2svg/pdf2svg-0.2.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-gfx/pdf2svg/pdf2svg-0.2.1.ebuild b/media-gfx/pdf2svg/pdf2svg-0.2.1.ebuild
new file mode 100644
index 000000000000..67858320961f
--- /dev/null
+++ b/media-gfx/pdf2svg/pdf2svg-0.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="pdf2svg is based on poppler and cairo and can convert pdf to svg files"
+HOMEPAGE="http://www.cityinthesky.co.uk/pdf2svg.html"
+SRC_URI="http://www.cityinthesky.co.uk/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=app-text/poppler-0.12.3-r3:=[cairo]
+ >=x11-libs/cairo-1.2.6:=[svg]
+ x11-libs/gtk+:2="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e 's:#include <stdio.h>:#include <stdio.h>\n#include <stdlib.h>:' \
+ ${PN}.c || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README
+}