summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/phototonic/phototonic-1.5.54.ebuild')
-rw-r--r--media-gfx/phototonic/phototonic-1.5.54.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-gfx/phototonic/phototonic-1.5.54.ebuild b/media-gfx/phototonic/phototonic-1.5.54.ebuild
new file mode 100644
index 000000000000..cc3f4daaba73
--- /dev/null
+++ b/media-gfx/phototonic/phototonic-1.5.54.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit qmake-utils
+
+DESCRIPTION="Image viewer and organizer"
+HOMEPAGE="http://oferkv.github.io/phototonic/"
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/oferkv/phototonic.git"
+else
+ SRC_URI="http://dev.gentoo.org/~yngwin/distfiles/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="svg tiff"
+
+RDEPEND="dev-qt/qtwidgets:5
+ dev-qt/qtgui:5
+ dev-qt/qtcore:5
+ media-gfx/exiv2:=
+ svg? ( dev-qt/qtsvg:5 )
+ tiff? ( dev-qt/qtimageformats:5 )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}