summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/pinta/pinta-1.4.ebuild')
-rw-r--r--media-gfx/pinta/pinta-1.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-gfx/pinta/pinta-1.4.ebuild b/media-gfx/pinta/pinta-1.4.ebuild
new file mode 100644
index 000000000000..2f27e1e0a1d2
--- /dev/null
+++ b/media-gfx/pinta/pinta-1.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit fdo-mime mono
+
+DESCRIPTION="Simple Painting for Gtk"
+HOMEPAGE="http://pinta-project.com"
+SRC_URI="mirror://github/PintaProject/Pinta/${P}.tar.gz"
+
+LICENSE="MIT CC-BY-3.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEPEND="dev-dotnet/atk-sharp:2
+ dev-dotnet/gdk-sharp:2
+ dev-dotnet/glib-sharp:2
+ dev-dotnet/gtk-sharp:2
+ dev-dotnet/mono-addins[gtk]
+ dev-dotnet/pango-sharp:2
+ dev-lang/mono"
+RDEPEND="${COMMON_DEPEND}
+ x11-libs/cairo[X]
+ x11-libs/gdk-pixbuf[X,jpeg,tiff]
+ x11-themes/gnome-icon-theme"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}