summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/swftools/swftools-0.9.2.ebuild')
-rw-r--r--media-gfx/swftools/swftools-0.9.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-gfx/swftools/swftools-0.9.2.ebuild b/media-gfx/swftools/swftools-0.9.2.ebuild
new file mode 100644
index 000000000000..8f0cd433c7d0
--- /dev/null
+++ b/media-gfx/swftools/swftools-0.9.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="SWF Tools is a collection of SWF manipulation and generation utilities"
+HOMEPAGE="http://www.swftools.org/"
+SRC_URI="http://www.swftools.org/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/poppler
+ >=media-libs/t1lib-1.3.1
+ media-libs/freetype
+ virtual/jpeg
+"
+DEPEND="${RDEPEND}
+ !<media-libs/ming-0.4.0_rc2
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}_nopdf.patch
+ epatch "${FILESDIR}"/${P}_general.patch
+ epatch "${FILESDIR}"/${P}_giflib.patch
+}
+
+src_configure() {
+ econf --enable-poppler
+ # disable the python interface; there's no configure switch; bug 118242
+ echo "all install uninstall clean:" > lib/python/Makefile
+}
+
+src_compile() {
+ emake FLAGS="${CFLAGS}"
+}
+
+src_install() {
+ einstall
+ dodoc AUTHORS ChangeLog
+}