summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/sxiv/files/sxiv-1.3-makefile.patch')
-rw-r--r--media-gfx/sxiv/files/sxiv-1.3-makefile.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/media-gfx/sxiv/files/sxiv-1.3-makefile.patch b/media-gfx/sxiv/files/sxiv-1.3-makefile.patch
new file mode 100644
index 000000000000..0640bf71af92
--- /dev/null
+++ b/media-gfx/sxiv/files/sxiv-1.3-makefile.patch
@@ -0,0 +1,30 @@
+--- sxiv-1.3/Makefile
++++ sxiv-1.3/Makefile
+@@ -3,10 +3,9 @@
+ PREFIX = /usr/local
+ MANPREFIX = $(PREFIX)/share/man
+
+-CC = gcc
+-CFLAGS = -std=c99 -Wall -pedantic -O2
+-CPPFLAGS = -I$(PREFIX)/include -D_XOPEN_SOURCE=500 -DHAVE_LIBEXIF -DHAVE_GIFLIB
+-LDFLAGS = -L$(PREFIX)/lib
++CC ?= gcc
++CFLAGS += -std=c99 -Wall -pedantic
++CPPFLAGS += -I$(PREFIX)/include -D_XOPEN_SOURCE=500 -DHAVE_LIBEXIF -DHAVE_GIFLIB
+ LIBS = -lX11 -lImlib2 -lexif -lgif
+
+ SRC = commands.c image.c main.c options.c thumbs.c util.c window.c
+@@ -18,11 +17,11 @@
+
+ depend: .depend
+
+-.depend: $(SRC)
++.depend: $(SRC) config.h
+ rm -f ./.depend
+ $(CC) $(CFLAGS) -MM $^ >./.depend
+
+-include .depend
++-include .depend
+
+ .c.o:
+ $(CC) $(CFLAGS) $(CPPFLAGS) -DVERSION=\"$(VERSION)\" -c -o $@ $<