summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/xsvg/xsvg-0.2.1.ebuild')
-rw-r--r--media-gfx/xsvg/xsvg-0.2.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-gfx/xsvg/xsvg-0.2.1.ebuild b/media-gfx/xsvg/xsvg-0.2.1.ebuild
new file mode 100644
index 000000000000..da41a89bb357
--- /dev/null
+++ b/media-gfx/xsvg/xsvg-0.2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit autotools eutils
+
+DESCRIPTION="a command line viewer for SVG files"
+HOMEPAGE="http://cairographics.org"
+SRC_URI="http://cairographics.org/snapshots/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/cairo[X]
+ x11-libs/libsvg-cairo"
+DEPEND="${RDEPEND}
+ x11-libs/libXt
+ x11-libs/libXcursor"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+}