summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gnome-photos/Manifest1
-rw-r--r--media-gfx/gnome-photos/gnome-photos-3.18.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/media-gfx/gnome-photos/Manifest b/media-gfx/gnome-photos/Manifest
index 4441e69631e1..be456bf4a7a3 100644
--- a/media-gfx/gnome-photos/Manifest
+++ b/media-gfx/gnome-photos/Manifest
@@ -1,2 +1,3 @@
DIST gnome-photos-3.16.2.tar.xz 762760 SHA256 9eb6a08a1d198f174f006b1c4e60a7db4f2e05cce7776e3f989470638cda2e20 SHA512 0c54789ac69541000d6fc67f3dc32af7b60041aaa7a580e38b91a2abc6d114216bd37573a185386dc6a8598c58844ed21a18af760aa59690c056c4da2b7736d6 WHIRLPOOL ac09949c35ab6266f15136a1dac35103fdb5f6f333710d110564af84906a095474cc218476c6eda08bd38f3d49526fd6f17412e58c202de576e24eafc07fb608
DIST gnome-photos-3.16.3.tar.xz 762584 SHA256 fb5a0232083369b80c95b700b41e9a3425b5bedd389ee08fed690d3f0989e129 SHA512 cefc899d260638511e0c2ce794043264c762b0bb0559cafee456853adc2cc2682ab8f535ffdf089417cb3668f609d34357e76436c8a0ed1206b86e068fb5bf92 WHIRLPOOL 3fd43e619e098d5fff352bd185721af0759a36838b37beca05a63da35e6ee73c8a6d9bca3a2029a8d697496e2665cec432a4923a772dab71f29813f338c4c724
+DIST gnome-photos-3.18.2.tar.xz 765196 SHA256 7f6169c663b7a0e1b971d5af4def3d9a633e16a24e7d2c593b51be0053f9a0d8 SHA512 40d3f67cc0dc4092349acf996572b08ef3f77560717f0fe612561d76eb3bead5e956ae9b585729ba489e8c427654c25c16086c9097bdbdc06045edf51d3e5e36 WHIRLPOOL 23e7181a24b73d33b03ef5d8d592c26e898589ed6e3f7eb8087393d82c12de37f7a5d0ccc3e085e5cd48567367fb7aa130a6566073229afd89e9e9abd29703b2
diff --git a/media-gfx/gnome-photos/gnome-photos-3.18.2.ebuild b/media-gfx/gnome-photos/gnome-photos-3.18.2.ebuild
new file mode 100644
index 000000000000..41d7a68e55f0
--- /dev/null
+++ b/media-gfx/gnome-photos/gnome-photos-3.18.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="Access, organize and share your photos on GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Photos"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=app-misc/tracker-1:=
+ >=dev-libs/glib-2.39.3:2
+ gnome-base/gnome-desktop:3=
+ >=gnome-base/librsvg-2.26.0
+ >=dev-libs/libgdata-0.15.2:0=
+ media-libs/babl
+ >=media-libs/gegl-0.3:0.3
+ >=media-libs/grilo-0.2.6:0.2
+ >=media-plugins/grilo-plugins-0.2.6:0.2[upnp-av]
+ >=media-libs/exempi-1.99.5
+ media-libs/lcms:2
+ >=media-libs/libexif-0.6.14
+ >=net-libs/gnome-online-accounts-3.8
+ >=net-libs/libgfbgraph-0.2.1:0.2
+ >=x11-libs/cairo-1.14
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.15.5:3
+"
+DEPEND="${RDEPEND}
+ dev-util/desktop-file-utils
+ >=dev-util/intltool-0.50.1
+ dev-util/itstool
+ virtual/pkgconfig
+ test? ( dev-util/dogtail )
+"
+# eautoreconf
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable test dogtail)
+}
+
+src_test() {
+ Xemake check
+}