summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/shotwell/files/0.30.14-vala-0.52.8-compat.patch13
-rw-r--r--media-gfx/shotwell/shotwell-0.30.14.ebuild5
2 files changed, 18 insertions, 0 deletions
diff --git a/media-gfx/shotwell/files/0.30.14-vala-0.52.8-compat.patch b/media-gfx/shotwell/files/0.30.14-vala-0.52.8-compat.patch
new file mode 100644
index 000000000000..0aef3e4eea96
--- /dev/null
+++ b/media-gfx/shotwell/files/0.30.14-vala-0.52.8-compat.patch
@@ -0,0 +1,13 @@
+diff --git a/src/dialogs/ExportDialog.vala b/src/dialogs/ExportDialog.vala
+index 5a61dc4a..c8011b7f 100644
+--- a/src/dialogs/ExportDialog.vala
++++ b/src/dialogs/ExportDialog.vala
+@@ -23,7 +23,7 @@ public class ExportDialog : Gtk.Dialog {
+
+ private static ScaleConstraint current_constraint = ScaleConstraint.ORIGINAL;
+ private static ExportFormatParameters current_parameters = ExportFormatParameters.current();
+- private static int current_scale = DEFAULT_SCALE;
++ private static int current_scale = 1200; //FIXME not needed with vala 0.54+
+
+ private Gtk.Grid table = new Gtk.Grid();
+ private Gtk.ComboBoxText quality_combo;
diff --git a/media-gfx/shotwell/shotwell-0.30.14.ebuild b/media-gfx/shotwell/shotwell-0.30.14.ebuild
index 629bc8a3d4c2..d0ee07286e10 100644
--- a/media-gfx/shotwell/shotwell-0.30.14.ebuild
+++ b/media-gfx/shotwell/shotwell-0.30.14.ebuild
@@ -50,6 +50,11 @@ BDEPEND="
app-crypt/gcr[vala]
"
+PATCHES=(
+ # Fix build against vala-0.52.8. Isn't needed once we use 0.54+ or drop vala:0.52 slots
+ "${FILESDIR}"/${PV}-vala-0.52.8-compat.patch
+)
+
src_prepare() {
xdg_src_prepare
vala_src_prepare