summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libvisio/libvisio-0.1.3-r1.ebuild')
-rw-r--r--media-libs/libvisio/libvisio-0.1.3-r1.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/media-libs/libvisio/libvisio-0.1.3-r1.ebuild b/media-libs/libvisio/libvisio-0.1.3-r1.ebuild
deleted file mode 100644
index 8c2449a7e3c1..000000000000
--- a/media-libs/libvisio/libvisio-0.1.3-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libvisio/"
-inherit autotools eutils
-[[ ${PV} == 9999 ]] && inherit git-r3
-
-DESCRIPTION="Library parsing the visio documents"
-HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
-[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
-
-LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
-IUSE="doc static-libs test tools"
-
-RDEPEND="
- dev-libs/icu:=
- dev-libs/librevenge
- dev-libs/libxml2
- sys-libs/zlib
-"
-DEPEND="${RDEPEND}
- >=dev-libs/boost-1.46
- dev-util/gperf
- sys-devel/libtool
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- test? ( dev-util/cppunit )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-tests.patch"
- "${FILESDIR}/${P}-fix-importtest.patch"
- "${FILESDIR}/${P}-tests-without-tools.patch"
- "${FILESDIR}/${P}-boost-1.59.patch"
-)
-
-src_prepare() {
- epatch "${PATCHES[@]}"
- epatch_user
- [[ -d m4 ]] || mkdir "m4"
- eautoreconf
-}
-
-src_configure() {
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- $(use_enable static-libs static) \
- --disable-werror \
- $(use_with doc docs) \
- $(use_enable test tests) \
- $(use_enable tools)
-}
-
-src_install() {
- default
- prune_libtool_files --all
-}