summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/sdl-gfx')
-rw-r--r--media-libs/sdl-gfx/Manifest1
-rw-r--r--media-libs/sdl-gfx/metadata.xml21
-rw-r--r--media-libs/sdl-gfx/sdl-gfx-2.0.25.ebuild44
3 files changed, 66 insertions, 0 deletions
diff --git a/media-libs/sdl-gfx/Manifest b/media-libs/sdl-gfx/Manifest
new file mode 100644
index 000000000000..a85f2acf7e59
--- /dev/null
+++ b/media-libs/sdl-gfx/Manifest
@@ -0,0 +1 @@
+DIST SDL_gfx-2.0.25.tar.gz 1760656 SHA256 556eedc06b6cf29eb495b6d27f2dcc51bf909ad82389ba2fa7bdc4dec89059c0 SHA512 42a5d78fe1a9b644d329fb688ed6c98558f8dd0aa029a1a0d99b1c59f94859269e0aef8f9e420b8018b687d8eae151652890be3994775644e1d3a80ba7b6fe8c WHIRLPOOL f3cac6a16c1fe1bcc8a09d5438cca8737ee571030524381804969c89d97ee4fd78e36625616932d4985504fc7689d765455d90a47692c9097119094612f72c9c
diff --git a/media-libs/sdl-gfx/metadata.xml b/media-libs/sdl-gfx/metadata.xml
new file mode 100644
index 000000000000..71195a1e8908
--- /dev/null
+++ b/media-libs/sdl-gfx/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+SDL graphics drawing primitives and other support functions
+The SDL_gfx library evolved out of the SDL_gfxPrimitives code which provided basic drawing
+routines such as lines, circles or polygons and SDL_rotozoom which implemented a
+interpolating rotozoomer for SDL surfaces.
+
+The current components of the SDL_gfx library are:
+
+ * Graphic Primitives (SDL_gfxPrimitves.h)
+ * Rotozoomer (SDL_rotozoom.h)
+ * Framerate control (SDL_framerate.h)
+ * MMX image filters (SDL_imageFilter.h)
+
+The library is backwards compatible to the above mentioned code. Its is written in plain C
+and can be used in C++ code.
+</longdescription>
+</pkgmetadata>
diff --git a/media-libs/sdl-gfx/sdl-gfx-2.0.25.ebuild b/media-libs/sdl-gfx/sdl-gfx-2.0.25.ebuild
new file mode 100644
index 000000000000..bf25598e99cc
--- /dev/null
+++ b/media-libs/sdl-gfx/sdl-gfx-2.0.25.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils multilib-minimal
+
+MY_P="${P/sdl-/SDL_}"
+DESCRIPTION="Graphics drawing primitives library for SDL"
+HOMEPAGE="http://www.ferzkopp.net/joomla/content/view/19/14/"
+SRC_URI="http://www.ferzkopp.net/Software/SDL_gfx-2.0/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc cpu_flags_x86_mmx static-libs"
+
+RDEPEND=">=media-libs/libsdl-1.2.15-r4[video,${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e 's/-O //' configure.in || die
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-dependency-tracking \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ dodoc AUTHORS ChangeLog README
+ use doc && dohtml -r Docs/*
+ prune_libtool_files
+}