summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/vdr-remote')
-rw-r--r--media-plugins/vdr-remote/Manifest2
-rw-r--r--media-plugins/vdr-remote/files/confd43
-rw-r--r--media-plugins/vdr-remote/files/rc-addon.sh97
-rw-r--r--media-plugins/vdr-remote/metadata.xml12
-rw-r--r--media-plugins/vdr-remote/vdr-remote-0.5.0-r1.ebuild30
-rw-r--r--media-plugins/vdr-remote/vdr-remote-0.5.0.ebuild19
-rw-r--r--media-plugins/vdr-remote/vdr-remote-0.6.0.ebuild29
7 files changed, 232 insertions, 0 deletions
diff --git a/media-plugins/vdr-remote/Manifest b/media-plugins/vdr-remote/Manifest
new file mode 100644
index 000000000000..8ead859cf4bd
--- /dev/null
+++ b/media-plugins/vdr-remote/Manifest
@@ -0,0 +1,2 @@
+DIST vdr-remote-0.5.0.tgz 31615 SHA256 d643e7c55857daf675474905803b5561ea81c2ff39522916c8c3d25b890ac4a5 SHA512 60575803d5d54a76f01fa4ceee0f9214d245f50f51c998c8aad7b28a0dc969ff12f083c147dd977a82372474e77dea9e625c509939e8b6367ac7548b61fbdc7f WHIRLPOOL 64e4edd9b062e846e729aa7c1155802e4657fdd46271f95910b120d1090af314d6d3ac24b60a3aafb74aafff68cd41d904f75f95f50ddba826a7c128c104674b
+DIST vdr-remote-0.6.0.tgz 32869 SHA256 c05d17f207bd2723ae6c079bc8961ba0badfcced149afbea63a5c52c807de254 SHA512 1836255d40c9a491d1f0dcab7779a3f75d125b4d28bce00954c2d774c83172e4d69763e34e3f7d9540a951faeead0c12d4a44b0a367a92caae3b22bb3f8c524d WHIRLPOOL f9e3c28e68cb75ea068596e470a5da92d843ff7b89c9b1c800fb8a6fc1fa7ddceaf9e44043755cc81d0d34efc70e19454f0ebb58ab60c6b4e4c51dc49f61736e
diff --git a/media-plugins/vdr-remote/files/confd b/media-plugins/vdr-remote/files/confd
new file mode 100644
index 000000000000..d34513c6d230
--- /dev/null
+++ b/media-plugins/vdr-remote/files/confd
@@ -0,0 +1,43 @@
+# /etc/conf.d/vdr.remote:
+
+# Config-file for vdr plugin remote
+
+#
+# Read keypresses from linux-kernel input-devices
+# for example IR-Input on DVB-cards
+# allowed values: no, autodetect or list of devices /dev/input/eventX (X=0,1,...)
+# default: autodetect
+#
+#REMOTE_PLUGIN_INPUT_DEVICE="no"
+#
+
+#
+# Connect to lirc-daemon on this socket
+# allowed values: list of sockets, example: /dev/lircd
+# default: do not use any lirc-daemon from inside this plugin
+#
+#REMOTE_PLUGIN_LIRC=""
+
+#
+# Listen on these tcp-ports for connections which get OSD and
+# can send keypresses to vdr
+# allowed values: List of portnumbers (>1024)
+# default: do not open any tcp-port
+#
+#REMOTE_PLUGIN_TCP_PORTS=""
+
+#
+# Listen on these tty-device for keypresses, do not show osd there
+# allowed values: List of tty-device names (/dev/ttyX)
+# default: do not open any tty-devices
+#
+#REMOTE_PLUGIN_TTY_ONLY_INPUT=""
+
+#
+# Listen on these tty-device for keypresses and show the
+# osd there
+# allowed values: List of tty-device names (/dev/ttyX)
+# default: do not open any tty-devices
+#
+#REMOTE_PLUGIN_TTY_WITH_OSD=""
+
diff --git a/media-plugins/vdr-remote/files/rc-addon.sh b/media-plugins/vdr-remote/files/rc-addon.sh
new file mode 100644
index 000000000000..5b5bdff49d18
--- /dev/null
+++ b/media-plugins/vdr-remote/files/rc-addon.sh
@@ -0,0 +1,97 @@
+#
+# rc-addon-script for plugin remote
+#
+
+check_device() {
+ local handlers="${1}"
+ local name="${2}"
+ local eventdev=""
+ [ "${handlers}" = "" ] && return
+
+ local handler
+ for handler in ${handlers}; do
+ case "${handler}" in
+ event*)
+ eventdev=${handler}
+ ;;
+ esac
+ done
+
+ if [ "${eventdev}" = "" ]; then
+ if [ "${evdev_warning_showed}" != "1" ]; then
+ echo "you need to load module evdev for autodetect input-devices to work"
+ evdev_warning_showed=1
+ fi
+ return
+ fi
+
+ case "${name}" in
+ *dvb*|*DVB*)
+ einfo_level1 "Autodetect Input Device ${eventdev} (Name: ${name})"
+ REMOTE_PLUGIN_INPUT_DEVICE="${REMOTE_PLUGIN_INPUT_DEVICE} /dev/input/${eventdev}"
+ ;;
+ esac
+}
+
+autodetect_input_devices() {
+ [ -e /proc/bus/input/devices ] || return
+ exec 3</proc/bus/input/devices
+ while read -u 3 line; do
+ case ${line} in
+ I:*) check_device "${device}" "${name}"
+ device=""
+ ;;
+ H:*) device=${line#H: Handlers=}
+ ;;
+ N:*) name=${line#N: Name=\"}
+ name=${name%\"}
+ ;;
+ esac
+ done
+ check_device "${device}" "${name}"
+ exec 3<&-
+}
+
+plugin_pre_vdr_start() {
+ if [ "${REMOTE_PLUGIN_INPUT_DEVICE:-autodetect}" = "autodetect" ]; then
+ REMOTE_PLUGIN_INPUT_DEVICE=""
+ autodetect_input_devices
+ fi
+ if [ -n "${REMOTE_PLUGIN_INPUT_DEVICE}" ] && [ "${REMOTE_PLUGIN_INPUT_DEVICE}" != "no" ]; then
+ [ -e /proc/av7110_ir ] && chown vdr:vdr /proc/av7110_ir
+ for dev in ${REMOTE_PLUGIN_INPUT_DEVICE}; do
+ [ -e "${dev}" ] || continue
+ chown vdr:vdr ${dev}
+ add_plugin_param "--input=${dev}"
+ done
+ fi
+
+ if [ -n "${REMOTE_PLUGIN_LIRC}" ]; then
+ for dev in ${REMOTE_PLUGIN_LIRC}; do
+ [ -e "${dev}" ] || continue
+ add_plugin_param "--lirc=${dev}"
+ done
+ fi
+
+ if [ -n "${REMOTE_PLUGIN_TCP_PORTS}" ]; then
+ for tcpport in ${REMOTE_PLUGIN_TCP_PORTS}; do
+ add_plugin_param "--port=tcp:${tcpport}"
+ done
+ fi
+
+ if [ -n "${REMOTE_PLUGIN_TTY_ONLY_INPUT}" ]; then
+ for tty in ${REMOTE_PLUGIN_TTY_ONLY_INPUT}; do
+ [ -e "${tty}" ] || continue
+ chown vdr:vdr ${tty}
+ add_plugin_param "--tty=${tty}"
+ done
+ fi
+
+ if [ -n "${REMOTE_PLUGIN_TTY_WITH_OSD}" ]; then
+ for tty in ${REMOTE_PLUGIN_TTY_WITH_OSD}; do
+ [ -e "${tty}" ] || continue
+ chown vdr:vdr ${tty}
+ add_plugin_param "--TTY=${tty}"
+ done
+ fi
+}
diff --git a/media-plugins/vdr-remote/metadata.xml b/media-plugins/vdr-remote/metadata.xml
new file mode 100644
index 000000000000..12de1a6a6a17
--- /dev/null
+++ b/media-plugins/vdr-remote/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+ <maintainer>
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+ </maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-remote/vdr-remote-0.5.0-r1.ebuild b/media-plugins/vdr-remote/vdr-remote-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..2ec9a48f2eba
--- /dev/null
+++ b/media-plugins/vdr-remote/vdr-remote-0.5.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: use various devices for controlling vdr (keyboards, lirc, remotes bundled with tv-cards)"
+HOMEPAGE="http://www.escape-edv.de/endriss/vdr/"
+SRC_URI="http://www.escape-edv.de/endriss/vdr/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd"
+
+DEPEND=">=media-video/vdr-2"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ vdr-plugin-2_pkg_setup
+
+ if use systemd; then
+ if ! getent group input | grep -q vdr; then
+ einfo "add user 'vdr' to group 'input' for full access to remote control device"
+ gpasswd -a vdr input
+ fi
+ fi
+}
diff --git a/media-plugins/vdr-remote/vdr-remote-0.5.0.ebuild b/media-plugins/vdr-remote/vdr-remote-0.5.0.ebuild
new file mode 100644
index 000000000000..936d96188487
--- /dev/null
+++ b/media-plugins/vdr-remote/vdr-remote-0.5.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: use various devices for controlling vdr (keyboards, lirc, remotes bundled with tv-cards)"
+HOMEPAGE="http://www.escape-edv.de/endriss/vdr/"
+SRC_URI="http://www.escape-edv.de/endriss/vdr/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.7.35"
+RDEPEND="${DEPEND}"
diff --git a/media-plugins/vdr-remote/vdr-remote-0.6.0.ebuild b/media-plugins/vdr-remote/vdr-remote-0.6.0.ebuild
new file mode 100644
index 000000000000..8a00ddcc714a
--- /dev/null
+++ b/media-plugins/vdr-remote/vdr-remote-0.6.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: use various devices for controlling vdr (keyboards, lirc, remotes bundled with tv-cards)"
+HOMEPAGE="http://www.escape-edv.de/endriss/vdr/"
+SRC_URI="http://www.escape-edv.de/endriss/vdr/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="systemd"
+
+DEPEND=">=media-video/vdr-2.2.0"
+
+pkg_setup() {
+ vdr-plugin-2_pkg_setup
+
+ if use systemd; then
+ if ! getent group input | grep -q vdr; then
+ einfo "add user 'vdr' to group 'input' for full access to remote control device"
+ gpasswd -a vdr input
+ fi
+ fi
+}