summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video')
-rw-r--r--media-video/obs-studio/metadata.xml3
-rw-r--r--media-video/obs-studio/obs-studio-9999.ebuild11
2 files changed, 10 insertions, 4 deletions
diff --git a/media-video/obs-studio/metadata.xml b/media-video/obs-studio/metadata.xml
index 89c066c043bd..cd2070e38ea0 100644
--- a/media-video/obs-studio/metadata.xml
+++ b/media-video/obs-studio/metadata.xml
@@ -19,6 +19,9 @@
<flag name="python">Build support for scripting via Python 3.</flag>
<flag name="speex">Enable noise suppression filter support via
<pkg>media-libs/speexdsp</pkg>.</flag>
+ <flag name="ssl">Build support for TLS/SSL connections (RTMPS) via
+ <pkg>net-libs/mbedtls</pkg>.</flag>
+ <flag name="vlc">Build support for using <pkg>media-video/vlc</pkg> as a media source.</flag>
</use>
<upstream>
<remote-id type="github">obsproject/obs-studio</remote-id>
diff --git a/media-video/obs-studio/obs-studio-9999.ebuild b/media-video/obs-studio/obs-studio-9999.ebuild
index d86c6eab4475..46578dd8dba1 100644
--- a/media-video/obs-studio/obs-studio-9999.ebuild
+++ b/media-video/obs-studio/obs-studio-9999.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+CMAKE_REMOVE_MODULES_LIST=( FindFreetype )
+PYTHON_COMPAT=( python3_{5,6,7} )
inherit cmake-utils python-single-r1 xdg-utils
@@ -21,7 +22,7 @@ HOMEPAGE="https://obsproject.com"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+alsa fdk imagemagick jack luajit nvenc pulseaudio python speex truetype v4l"
+IUSE="+alsa fdk imagemagick jack luajit nvenc pulseaudio python speex +ssl truetype v4l vlc"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
BDEPEND="
@@ -60,16 +61,16 @@ DEPEND="
pulseaudio? ( media-sound/pulseaudio )
python? ( ${PYTHON_DEPS} )
speex? ( media-libs/speexdsp )
+ ssl? ( net-libs/mbedtls )
truetype? (
media-libs/fontconfig
media-libs/freetype
)
v4l? ( media-libs/libv4l )
+ vlc? ( media-video/vlc:= )
"
RDEPEND="${DEPEND}"
-CMAKE_REMOVE_MODULES_LIST=( FindFreetype )
-
pkg_setup() {
use python && python-single-r1_pkg_setup
}
@@ -84,9 +85,11 @@ src_configure() {
-DDISABLE_PULSEAUDIO=$(usex !pulseaudio)
-DDISABLE_SPEEXDSP=$(usex !speex)
-DDISABLE_V4L2=$(usex !v4l)
+ -DDISABLE_VLC=$(usex !vlc)
-DLIBOBS_PREFER_IMAGEMAGICK=$(usex imagemagick)
-DOBS_MULTIARCH_SUFFIX=${libdir#lib}
-DUNIX_STRUCTURE=1
+ -DWITH_RTMPS=$(usex ssl)
)
if use luajit || use python; then