summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/firewalld/Manifest1
-rw-r--r--net-firewall/firewalld/files/firewalld.init4
-rw-r--r--net-firewall/firewalld/firewalld-0.6.3.ebuild100
3 files changed, 103 insertions, 2 deletions
diff --git a/net-firewall/firewalld/Manifest b/net-firewall/firewalld/Manifest
index 867d62e1570c..ab80ac826572 100644
--- a/net-firewall/firewalld/Manifest
+++ b/net-firewall/firewalld/Manifest
@@ -1 +1,2 @@
DIST firewalld-0.5.1.tar.gz 1155989 BLAKE2B 8e5f67dc74738cec178715b0e3713afa7296be61b376a8d545b1ae1c01c0f0df78ec48222b6926bdce1d93c58f7d02fad14bc46c1ddd24840e8853e5e76b73ff SHA512 8c8ea1a07fc81b12f53fbc84112d18c65c4332e8f7b7d575dc1ccba8a12418c874f8503b0062b49990f8bcfdf5fdaa7c0e4e3ddc0e9b1d0a91f49eff284b22be
+DIST firewalld-0.6.3.tar.gz 2294470 BLAKE2B 09bb971d8142e5d28b6a085527e7f5275090f15e5dc4ccf2b16b6ed837049ed75443b09a54db76e37c6f0c5db6524ba85cf34c5117c1139bba0e3b223f289d57 SHA512 ea9e8bad34d3608257ef2a38851855974eff97b21dbab93ca3d8cfad90339734a8124447ed531a978b41546ab4040135bb61c8fdc9677ba0df9188d7ee4422ee
diff --git a/net-firewall/firewalld/files/firewalld.init b/net-firewall/firewalld/files/firewalld.init
index 2618338e9f81..3bd3623de868 100644
--- a/net-firewall/firewalld/files/firewalld.init
+++ b/net-firewall/firewalld/files/firewalld.init
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
description="FirewallD"
@@ -8,5 +8,5 @@ pidfile=/var/run/firewalld.pid
depend() {
need dbus
- provide iptables ip6tables ebtables
+ provide firewall
}
diff --git a/net-firewall/firewalld/firewalld-0.6.3.ebuild b/net-firewall/firewalld/firewalld-0.6.3.ebuild
new file mode 100644
index 000000000000..fc1c2cde7883
--- /dev/null
+++ b/net-firewall/firewalld/firewalld-0.6.3.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit autotools gnome2-utils linux-info python-single-r1 systemd bash-completion-r1
+
+DESCRIPTION="A firewall daemon with D-BUS interface providing a dynamic firewall"
+HOMEPAGE="http://www.firewalld.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="gui"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ !!net-firewall/gshield
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ >=dev-python/python-slip-0.2.7[dbus,${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ net-firewall/ebtables
+ net-firewall/iptables[ipv6]
+ net-firewall/ipset
+ net-firewall/nftables
+ || ( >=sys-apps/openrc-0.11.5 sys-apps/systemd )
+ gui? (
+ x11-libs/gtk+:3
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ dev-libs/glib:2
+ >=dev-util/intltool-0.35
+ sys-devel/gettext"
+
+RESTRICT="test" # bug 650760
+
+pkg_setup() {
+ local CONFIG_CHECK="~NF_CONNTRACK ~NF_CONNTRACK_IPV4 ~NF_CONNTRACK_IPV6 ~NETFILTER_XT_MATCH_CONNTRACK"
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ python_setup
+
+ econf \
+ --enable-systemd \
+ --with-iptables="${EPREFIX}/sbin/iptables" \
+ --with-ip6tables="${EPREFIX}/sbin/ip6tables" \
+ --with-iptables_restore="${EPREFIX}/sbin/iptables-restore" \
+ --with-ip6tables_restore="${EPREFIX}/sbin/ip6tables-restore" \
+ --with-ebtables="${EPREFIX}/sbin/ebtables" \
+ --with-ebtables_restore="${EPREFIX}/sbin/ebtables-restore" \
+ --with-nft="${EPREFIX}/sbin/nft" \
+ --with-systemd-unitdir="$(systemd_get_systemunitdir)" \
+ --with-bashcompletiondir="$(get_bashcompdir)"
+}
+
+src_install() {
+ default
+ python_optimize
+
+ # Get rid of junk
+ rm -rf "${D}/etc/rc.d/" || die
+ rm -rf "${D}/etc/sysconfig/" || die
+
+ # For non-gui installs we need to remove GUI bits
+ if ! use gui; then
+ rm -rf "${D}/etc/xdg/autostart" || die
+ rm -f "${D}/usr/bin/firewall-applet" || die
+ rm -f "${D}/usr/bin/firewall-config" || die
+ rm -rf "${D}/usr/share/applications" || die
+ rm -rf "${D}/usr/share/icons" || die
+ fi
+
+ newinitd "${FILESDIR}"/firewalld.init firewalld
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}